aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMarvin Steadfast <marvin@xsteadfastx.org>2017-04-20 12:42:38 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-04-27 09:20:24 +0300
commitf94fcc8721ce42fed95b98ff8263b5e03ae1ee15 (patch)
treed3f1ad18496919a8bf809f3086009b25b163d64e /testing
parent881b9b74e4a629a3bdc80fb68afd1e8a85928e73 (diff)
downloadaports-f94fcc8721ce42fed95b98ff8263b5e03ae1ee15.tar.bz2
aports-f94fcc8721ce42fed95b98ff8263b5e03ae1ee15.tar.xz
testing/mopidy: updated to 2.1.0
moved pkg from unmaintained to testing and made needed changes to get the new version running.
Diffstat (limited to 'testing')
-rw-r--r--testing/mopidy/APKBUILD52
-rw-r--r--testing/mopidy/mopidy.conf8
2 files changed, 60 insertions, 0 deletions
diff --git a/testing/mopidy/APKBUILD b/testing/mopidy/APKBUILD
new file mode 100644
index 0000000000..91a5a27f0a
--- /dev/null
+++ b/testing/mopidy/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Łukasz Jendrysik <scadu@yandex.com>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
+pkgname=mopidy
+_pkgname=Mopidy
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Mopidy is an extensible music server"
+url="http://www.mopidy.com/"
+arch="noarch"
+license="ASL 2.0"
+depends="python py-pykka py-tornado gst-plugins-base1 gst-plugins-good1
+ gst-plugins-ugly1 py-gst1 py-setuptools py-libxml2 py-requests
+ py-six
+ "
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ mopidy.conf
+ "
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ default_prepare
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm640 "${srcdir}/mopidy.conf" "${pkgdir}/etc/mopidy/mopidy.conf"
+ install -dm755 "${pkgdir}/etc/mopidy/extensions.d"
+ install -dm755 "${pkgdir}/var/cache/mopidy"
+ install -dm755 "${pkgdir}/var/log/mopidy"
+ install -dm755 "${pkgdir}/var/lib/mopidy/local"
+ install -dm755 "${pkgdir}/var/lib/mopidy/media"
+ install -dm755 "${pkgdir}/var/lib/mopidy/playlists"
+}
+
+check() {
+ cd "$_builddir"
+ python -m mopidy --help > /dev/null
+}
+
+sha512sums="14422ec706be70b3ce64e48be2c07677ac19fbb3a66f7ee4c9ad84ce47ffd8bf8a8b43edb7655f8437c50ac1366026ab96594f6598e033db8ffe094dd471d985 Mopidy-2.1.0.tar.gz
+593f872d072b32d3da92b8e60ad486c9ca6fa68eae5235e7724f3837d1fa4627694b5ebc8aaacedfba22c701e558e1d60b2f9c97139621a0eead3319446fe300 mopidy.conf"
diff --git a/testing/mopidy/mopidy.conf b/testing/mopidy/mopidy.conf
new file mode 100644
index 0000000000..95b8b423ac
--- /dev/null
+++ b/testing/mopidy/mopidy.conf
@@ -0,0 +1,8 @@
+[logging]
+debug_file = /var/log/mopidy/mopidy-debug.log
+
+[local]
+enabled = true
+data_dir = /var/lib/mopidy/local
+media_dir = /var/lib/mopidy/media
+playlists_dir = /var/lib/mopidy/playlists