aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-27 19:20:06 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-27 19:27:00 +0000
commitfda86691c22f67327a08e3b68ae3ead7fc1b6f9c (patch)
treece5263f6faa69b27dad6fbd9d125488209fb2a0f /testing
parent500f378f52a862e91c61de633df00197d4afd366 (diff)
downloadaports-fda86691c22f67327a08e3b68ae3ead7fc1b6f9c.tar.bz2
aports-fda86691c22f67327a08e3b68ae3ead7fc1b6f9c.tar.xz
testing/libgnomecanvas: Build on ppc64le
Currently libgnomecanvas does not build on ppc64le due to old config.guess file. This patch just update config.guess before compiling the package.
Diffstat (limited to 'testing')
-rw-r--r--testing/libgnomecanvas/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/testing/libgnomecanvas/APKBUILD b/testing/libgnomecanvas/APKBUILD
index ac018d26f6..ff8fbfe53d 100644
--- a/testing/libgnomecanvas/APKBUILD
+++ b/testing/libgnomecanvas/APKBUILD
@@ -12,6 +12,11 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
builddir="$srcdir/"$pkgname-$pkgver
+prepare() {
+ update_config_guess
+ default_prepare
+}
+
build() {
cd "$builddir"
./configure --prefix=/usr