aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-08 01:55:26 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-08 01:56:37 +0100
commit339244bc540e25295c5a4d055d209fa19320a9d2 (patch)
tree23c9fa4d321340b91e49d4ce3c2d7b92ed7c7a9f /testing
parentf712f9a685c81c6f343320e676a2f0740bccff53 (diff)
downloadaports-339244bc540e25295c5a4d055d209fa19320a9d2.tar.bz2
aports-339244bc540e25295c5a4d055d209fa19320a9d2.tar.xz
testing/ucl: add -dev subpkg, check() func and improve abuild
Diffstat (limited to 'testing')
-rw-r--r--testing/ucl/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/testing/ucl/APKBUILD b/testing/ucl/APKBUILD
index 196bd6c15f..b9e73b9ae0 100644
--- a/testing/ucl/APKBUILD
+++ b/testing/ucl/APKBUILD
@@ -1,17 +1,15 @@
-#-*-mode: Shell-script; coding: utf-8;-*-
# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
pkgname=ucl
pkgver=1.03
-pkgrel=0
+pkgrel=1
pkgdesc="Portable lossless data compression library written in ANSI C"
url="http://www.oberhumer.com/opensource/ucl/"
arch="all"
-license="gpl"
+license="GPL2"
makedepends="file"
-source="
- http://www.oberhumer.com/opensource/$pkgname/download/$pkgname-$pkgver.tar.gz
- 0001-Static-assert.patch
-"
+subpackages="$pkgname-dev"
+source="http://www.oberhumer.com/opensource/$pkgname/download/$pkgname-$pkgver.tar.gz
+ 0001-Static-assert.patch"
prepare() {
default_prepare || return 1
@@ -21,17 +19,24 @@ prepare() {
build() {
cd "$builddir"
- ./configure --prefix=/usr --enable-shared --enable-static || return 1
+
+ ./configure \
+ --prefix=/usr \
+ --enable-shared \
+ --enable-static \
+ || return 1
make || return 1
}
+check() {
+ cd "$builddir"
+ ./examples/simple
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="852bd691d8abc75b52053465846fba34 ucl-1.03.tar.gz
-e852ab6af348477e6c6b3f1ee41b2200 0001-Static-assert.patch"
-sha256sums="b865299ffd45d73412293369c9754b07637680e5c826915f097577cd27350348 ucl-1.03.tar.gz
-b0269e9f934e23a5992acffe193a27892cd47d91a7e0d65cb6a91e2131896a65 0001-Static-assert.patch"
+
sha512sums="7dd1824d01b4bb41ee03bbceddc634a9f7f910d235e5cca163d783680d6743f0f3cc309bbbcc1e094d897d549d3805a555f9093b4d77805443d896dd1862aa34 ucl-1.03.tar.gz
24a34de871fcfa919985afc29c60496b1f0e730550e8387f212a5229f32ccade4178d1221574d86c36d025c08b3b5ed6d236f2b4d740436afe0451ae9050f890 0001-Static-assert.patch"