aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorxming <xmingske@gmail.com>2014-10-23 07:34:22 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-23 10:19:13 +0200
commit391ed7e3f38ef678dcc3fed87de1352a1ad98bfb (patch)
tree186417d78f96c5e485e09b14abcc947e3c3f50b4 /testing
parent2c8ba84e93592984f158c64da06a840793c7474e (diff)
downloadaports-391ed7e3f38ef678dcc3fed87de1352a1ad98bfb.tar.bz2
aports-391ed7e3f38ef678dcc3fed87de1352a1ad98bfb.tar.xz
testing/libevhtp: new aport
Flexible replacement for libevent's httpd API https://github.com/ellzey/libevhtp/
Diffstat (limited to 'testing')
-rw-r--r--testing/libevhtp/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/libevhtp/APKBUILD b/testing/libevhtp/APKBUILD
new file mode 100644
index 0000000000..911dbb814e
--- /dev/null
+++ b/testing/libevhtp/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libevhtp
+pkgver=1.1.7
+pkgrel=0
+pkgdesc="Flexible replacement for libevent's httpd API"
+url="https://github.com/ellzey/libevhtp/"
+arch="all"
+license="BSD"
+makedepends="cmake libevent-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ellzey/libevhtp/archive/${pkgver}.tar.gz"
+#subpackages="$pkgname-dev"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ cmake -DCUSTOM_BINDIR=/usr/bin \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCUSTOM_DOCDIR="/usr/share/doc/${pkgname}" \
+ -DCUSTOM_SHAREDIR="/usr/share/${pkgname}" \
+ .
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="b29d5df06e09e90f2d585172d7f3d7a6 libevhtp-1.1.7.tar.gz"
+sha256sums="8bdfd87f09c898098a60c3618df29527c93b160a72ed7819769905ecddae1332 libevhtp-1.1.7.tar.gz"
+sha512sums="e5cda76877b15de97fcce85149c97c221548bc6b59fb9cf56404adbfd748aaf4cfeeba12e5facfbecfd46252924a37e0098d0f533912effdd03def56fd5d3aa6 libevhtp-1.1.7.tar.gz"