aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-04 14:28:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-04 14:28:15 +0000
commit8f8901be0a991ce977fdca900b07afeddf9d0824 (patch)
tree224b957acc2f13ac6fe0f3e308fbe503d9c73dd5 /testing
parent4f13e09e75ef8a6185f81296a9a1f5a17f93fa13 (diff)
downloadaports-8f8901be0a991ce977fdca900b07afeddf9d0824.tar.bz2
aports-8f8901be0a991ce977fdca900b07afeddf9d0824.tar.xz
testing/py-openssl: new aport
Python wrapper module around the OpenSSL library http://pyopenssl.sourceforge.net/
Diffstat (limited to 'testing')
-rw-r--r--testing/py-openssl/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py-openssl/APKBUILD b/testing/py-openssl/APKBUILD
new file mode 100644
index 0000000000..bcfc38ef8e
--- /dev/null
+++ b/testing/py-openssl/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor:
+# Maintainer:
+pkgname=py-openssl
+pkgver=0.13
+pkgrel=0
+pkgdesc="Python wrapper module around the OpenSSL library"
+url="http://pyopenssl.sourceforge.net/"
+arch="all"
+license="ASL 2.0"
+depends=""
+depends_dev=""
+makedepends="$depends_dev openssl-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pyOpenSSL-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="767bca18a71178ca353dff9e10941929 pyOpenSSL-0.13.tar.gz"