aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-25 12:46:02 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-25 12:47:42 +0000
commitba4a729fd10343f8da33b443d2fc27878ac34f03 (patch)
treea1cc3aaf3a05f0aaab225101bce84e3465520bcd /testing
parentfc91b90cc19a3733c399ab07b8310be4a38f45f4 (diff)
downloadaports-ba4a729fd10343f8da33b443d2fc27878ac34f03.tar.bz2
aports-ba4a729fd10343f8da33b443d2fc27878ac34f03.tar.xz
testing/perl-specio: modernize and add check
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-specio/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/testing/perl-specio/APKBUILD b/testing/perl-specio/APKBUILD
index df9ec6ee24..afcde58970 100644
--- a/testing/perl-specio/APKBUILD
+++ b/testing/perl-specio/APKBUILD
@@ -3,27 +3,31 @@
pkgname=perl-specio
_pkgname=Specio
pkgver=0.36
-pkgrel=1
+pkgrel=2
pkgdesc="Type constraints and coercions for Perl"
url="https://github.com/houseabsolute/Specio"
-arch="all"
+arch="noarch"
license="Artistic"
depends="perl"
-makedepends=""
-install=""
+checkdepends="perl-test-fatal perl-test-needs perl-eval-closure perl-mro-compat perl-role-tiny perl-devel-stacktrace perl-module-runtime perl-moo"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/houseabsolute/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}