aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2009-06-09 14:21:19 +0000
committerLeonardo Arena <rnalrd@gmail.com>2009-06-09 14:21:19 +0000
commitf4c1f64b5d99c7ed61971c1dd1a3b770996ff860 (patch)
treefc2c6e892e1e7886d467c1fb697d88b15853166a /testing
parent096a9d3cd1a70f0aba6f278b0f11b61b27092ef8 (diff)
downloadaports-f4c1f64b5d99c7ed61971c1dd1a3b770996ff860.tar.bz2
aports-f4c1f64b5d99c7ed61971c1dd1a3b770996ff860.tar.xz
testing/perl-crypt-openssl-random: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-crypt-openssl-random/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/perl-crypt-openssl-random/APKBUILD b/testing/perl-crypt-openssl-random/APKBUILD
new file mode 100644
index 0000000000..0b1e8ea995
--- /dev/null
+++ b/testing/perl-crypt-openssl-random/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-crypt-openssl-random
+_realname=Crypt-OpenSSL-Random
+pkgver=0.04
+pkgrel=0
+pkgdesc="RSA encoding and decoding, using the openSSL libraries"
+url="http://search.cpan.org/~iroberts/Crypt-OpenSSL-Random-0.04/"
+license="Unknown"
+depends="perl"
+makedepends="perl-dev openssl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/I/IR/IROBERTS/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ rm $pkgdir/usr/lib/perl5/5.10.0/i686-linux/perllocal.pod
+}
+
+md5sums="c56ac5dbdd46122eb9b8da59613b7b0a Crypt-OpenSSL-Random-0.04.tar.gz"