aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-09-19 14:18:53 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-09-19 14:19:55 +0000
commitb91b34fdba7939f494529d554a6f9cc025890fa6 (patch)
tree13549316f7970916f640b804b82154233f9bb459 /testing
parent7e0a33aaa4cd1971248886c61fd94d348f29553e (diff)
downloadaports-b91b34fdba7939f494529d554a6f9cc025890fa6.tar.bz2
aports-b91b34fdba7939f494529d554a6f9cc025890fa6.tar.xz
testing/uci: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/uci/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/uci/APKBUILD b/testing/uci/APKBUILD
new file mode 100644
index 0000000000..51f13c8963
--- /dev/null
+++ b/testing/uci/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=uci
+pkgver=0_git20150919
+pkgrel=0
+pkgdesc="Library and utility for the Unified Configuration Interface for OpenWrt"
+url="http://nbd.name/gitweb.cgi?p=uci.git"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev cmake libubox"
+subpackages="$pkgname-dev"
+install=
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ "
+giturl="git://nbd.name/uci.git"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake CMakeLists.txt -DBUILD_LUA=OFF -DCMAKE_INSTALL_PREFIX=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ class="western"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="d50257b0adedc8fb82a3b90f43830adc uci-0_git20150919.tar.gz"
+sha256sums="5d91c0c80e9bc14b85cdc2f622e2c0c8e1c2ba20a1e7d496cd49536b135c0479 uci-0_git20150919.tar.gz"
+sha512sums="8c2d9fe4492be3231049ab8899ac232b663f31c73a5c857f92d77eccdf3a3bd83967b611cc59b1f507449e030487eb3511214229aa257f426afc72463ed211f7 uci-0_git20150919.tar.gz"