aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-05 19:12:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-05 19:12:52 +0000
commit65f5d8823df03d86c1a68c69c46f45b11baa4b33 (patch)
treef5d23c4377988ef51641f994020228f8c5bb5b26 /testing
parenta7a3ff3d26183ef8a698c6e30ffc616e50982f6f (diff)
downloadaports-65f5d8823df03d86c1a68c69c46f45b11baa4b33.tar.bz2
aports-65f5d8823df03d86c1a68c69c46f45b11baa4b33.tar.xz
testing/postler: new aport
Email client https://launchpad.net/postler/
Diffstat (limited to 'testing')
-rw-r--r--testing/postler/APKBUILD42
-rw-r--r--testing/postler/inet_ntoa.patch10
2 files changed, 52 insertions, 0 deletions
diff --git a/testing/postler/APKBUILD b/testing/postler/APKBUILD
new file mode 100644
index 0000000000..d4acf07b9c
--- /dev/null
+++ b/testing/postler/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=postler
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Email client"
+url="https://launchpad.net/postler/"
+arch="all"
+license="LGPL-2.1"
+depends="msmtp"
+makedepends="gtk+-dev webkit-dev libunique-dev libnotify-dev libcanberra-dev
+ python vala db-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.twotoasts.de/media/postler-$pkgver.tar.bz2
+ inet_ntoa.patch"
+
+_builddir="$srcdir"/postler-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./waf configure --prefix=/usr \
+ --disable-libindicate \
+ || return 1
+ ./waf build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ ./waf install --destdir="$pkgdir" || return 1
+}
+
+md5sums="0247cdf1ab8e2d919c9299a52646f47a postler-0.1.0.tar.bz2
+06bb9bb2d1a809b6e58b2a5012393151 inet_ntoa.patch"
diff --git a/testing/postler/inet_ntoa.patch b/testing/postler/inet_ntoa.patch
new file mode 100644
index 0000000000..bbb0969bc2
--- /dev/null
+++ b/testing/postler/inet_ntoa.patch
@@ -0,0 +1,10 @@
+--- a/wscript
++++ b/wscript
+@@ -141,7 +141,6 @@
+ includes=['/usr/local/include/db42'],
+ libpath=['/usr/local/lib/db42'], lib='db', mandatory=True)
+ else:
+- check_function ('inet_ntoa', 'arpa/inet.h', 'nsl')
+ check_function ('dlopen', 'dlfcn.h', 'dl')
+ check_function ('db_create', 'db.h', 'db')
+ check_pkg ('openssl')