aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-09 12:05:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-09 12:05:48 +0000
commitfef0c16184c075c9814b6373e5b70cdbf6c06fc3 (patch)
tree0a33465ee78f248a44c4d0535f2f7d3b8fde6ad0 /testing
parentc29e6f0766ff2bed9e21decfe1ead23817041aa2 (diff)
downloadaports-fef0c16184c075c9814b6373e5b70cdbf6c06fc3.tar.bz2
aports-fef0c16184c075c9814b6373e5b70cdbf6c06fc3.tar.xz
testing/libavc1394: new aport
Audio/Video Control library for IEEE-1394 devices http://sourceforge.net/projects/libavc1394/
Diffstat (limited to 'testing')
-rw-r--r--testing/libavc1394/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/libavc1394/APKBUILD b/testing/libavc1394/APKBUILD
new file mode 100644
index 0000000000..6f420fb85a
--- /dev/null
+++ b/testing/libavc1394/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libavc1394
+pkgver=0.5.3
+pkgrel=0
+pkgdesc="Audio/Video Control library for IEEE-1394 devices"
+url="http://sourceforge.net/projects/libavc1394/"
+arch="all"
+license="GPLv2+ LGPLv2+"
+depends=
+depends_dev="libraw1394-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/libavc1394/libavc1394-$pkgver.tar.gz"
+
+_builddir="$srcdir"/libavc1394-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="09e30b1fb5ae455b6d8407e457a711a3 libavc1394-0.5.3.tar.gz"