aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-10 11:47:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-10 12:46:50 +0000
commit0c2c1652b2e5d74ea61ffdf6eb91325ee9f2093e (patch)
tree3bc4efa1bbf77e3bcc63838295151c211e587ba6 /testing
parent4e8f7ad610f304426599f02a7c7c16dbfc386cb4 (diff)
downloadaports-0c2c1652b2e5d74ea61ffdf6eb91325ee9f2093e.tar.bz2
aports-0c2c1652b2e5d74ea61ffdf6eb91325ee9f2093e.tar.xz
testing/lua-zmq: new aport
Lua zeromq2 binding https://github.com/Neopallium/lua-zmq
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-zmq/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/lua-zmq/APKBUILD b/testing/lua-zmq/APKBUILD
new file mode 100644
index 0000000000..1cf29100fb
--- /dev/null
+++ b/testing/lua-zmq/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-zmq
+pkgver=1.1
+pkgrel=0
+pkgdesc="Lua zeromq2 binding"
+url="https://github.com/Neopallium/lua-zmq"
+arch="all"
+license="MIT"
+depends=""
+makedepends="wget zeromq-dev cmake"
+install=""
+subpackages=
+source="saveas-http://github.com/Neopallium/lua-zmq/tarball/v1.1/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Neopallium-lua-zmq-5cf558e
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="d3813c48a9e2b88426fd79604862966d lua-zmq-1.1.tar.gz"