aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-01-28 12:37:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-01-28 12:37:49 +0000
commit06af197923ee6f7d470cb7f8b5e480cdb14370e6 (patch)
tree7a944eedc19c6ed78835fe97b8ef32f718445bbd /testing
parent574ebbfe36a991b32144d5ea3626f701dcb0787b (diff)
downloadaports-06af197923ee6f7d470cb7f8b5e480cdb14370e6.tar.bz2
aports-06af197923ee6f7d470cb7f8b5e480cdb14370e6.tar.xz
testing/apr: new aport
Apache Portable Runtime Library http://apr.apache.org/
Diffstat (limited to 'testing')
-rw-r--r--testing/apr/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/apr/APKBUILD b/testing/apr/APKBUILD
new file mode 100644
index 0000000000..275d6680e9
--- /dev/null
+++ b/testing/apr/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=apr
+pkgver=1.3.3
+pkgrel=0
+pkgdesc="The Apache Portable Runtime"
+url="http://apr.apache.org/"
+license="APACHE"
+depends="libuuid"
+makedepends="e2fsprogs-dev"
+subpackages="$pkgname-dev"
+source="http://www.apache.org/dist/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --enable-nonportable-atomics \
+ --with-devrandom=/dev/urandom
+ make || return 1
+ make DESTDIR=${pkgdir} install
+}
+
+# basicly everything thats not a *.so* file belongs to the -dev package
+# we override the pre-defined func.
+dev() {
+ local i
+ depends="$pkgname"
+ mkdir -p "$subpkgdir"
+ mv "$pkgdir"/* "$subpkgdir"/
+ mkdir -p "$pkgdir"/usr/lib
+ mv "$subpkgdir"/usr/lib/*.so* "$pkgdir"/usr/lib/
+ return 0
+}
+
+md5sums="2090c21dee4f0eb1512604127dcd158f apr-1.3.3.tar.bz2"