aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-26 07:33:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-26 09:11:17 +0000
commit0fd58f14fe348e7bc85dc268899b86e116b9c2dd (patch)
treee0eb3958adedd591b1f8cc7ce7a6fed9a9b7923d /testing
parent1f91940840d9ef21c64c5645951721520e3e6299 (diff)
downloadaports-0fd58f14fe348e7bc85dc268899b86e116b9c2dd.tar.bz2
aports-0fd58f14fe348e7bc85dc268899b86e116b9c2dd.tar.xz
testing/lua-xctrl: new aport
Lua module that allows you to query and manipulate various aspects of an X11 window manager http://jkp.t35.com/lua/
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-xctrl/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/lua-xctrl/APKBUILD b/testing/lua-xctrl/APKBUILD
new file mode 100644
index 0000000000..509cd7bec1
--- /dev/null
+++ b/testing/lua-xctrl/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor:
+# Maintainer:
+pkgname=lua-xctrl
+pkgver=2010.10.22
+_x=${pkgver%%.*}
+_y=${pkgver%.*}
+_y=${_y#*.}
+_z=${pkgver##*.}
+_ver=${_x}-${_y}-${_z}
+pkgrel=0
+pkgdesc="Lua module that allows you to query and manipulate various aspects of an X11 window manager"
+url="http://jkp.t35.com/lua/"
+license="GPL-2"
+depends=
+makedepends="lua-dev libx11-dev libxmu-dev libiconv-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://jkp.t35.com/files/xctrl-$_ver.tar.gz"
+
+_builddir="$srcdir"/xctrl-$_ver
+_lua_libdir=/usr/lib/lua/5.1
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ export EXTRA_CFLAGS="-fPIC"
+ export EXTRA_LDFLAGS="-liconv"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/$_lua_libdir "$pkgdir"/usr/share/doc/$pkgname
+ install src/xctrl.so "$pkgdir"/$_lua_libdir/xctrl.so
+ install doc/lwmctrl.html "$pkgdir"/usr/share/doc/$pkgname/lwmctrl.html
+}
+
+md5sums="8a234fb4fc143407a4a7788882665e49 xctrl-2010-10-22.tar.gz"