aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-11-01 08:30:33 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-11-01 08:30:33 +0000
commit49bb87ab33a6bccd8205f8b2467ed1a346230d8c (patch)
tree8deeb8fd70d5926c5280496ed3bdb736ee579534 /testing
parent18ae09e99e4ad3312b71e5f83a80e53c597e1a69 (diff)
downloadaports-49bb87ab33a6bccd8205f8b2467ed1a346230d8c.tar.bz2
aports-49bb87ab33a6bccd8205f8b2467ed1a346230d8c.tar.xz
testing/perl-dbd-mysql: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-dbd-mysql/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/perl-dbd-mysql/APKBUILD b/testing/perl-dbd-mysql/APKBUILD
new file mode 100644
index 0000000000..61fb79aff0
--- /dev/null
+++ b/testing/perl-dbd-mysql/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Jeff Bilyk <jbilyk at gmail>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-dbd-mysql
+_realpkgname=DBD-mysql
+pkgver=4.014
+pkgrel=0
+pkgdesc="Perl CPAN DBD::Mysql module"
+url="http://search.cpan.org/dist/${_realpkgname}"
+license="GPL PerlArtistic"
+depends="libmysqlclient perl perl-dbi"
+makedepends="perl perl-dev mysql-dev zlib-dev"
+source="http://www.cpan.org/authors/id/C/CA/CAPTTOFU/${_realpkgname}-$pkgver.tar.gz"
+
+_builddir="$srcdir"/${_realpkgname}-$pkgver
+
+prepare() {
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="74f118a4984e6a49f8ece28e68caf543 DBD-mysql-4.014.tar.gz"