aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-10-26 09:44:49 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-10-26 09:44:49 +0000
commit650c08badb6229254f7625ffdbb9e566558e3649 (patch)
treea6d8641680b784f18b7c7766692100c12dd1577e /testing
parent5de5094384d557f870ff2406a8bc02e251aab388 (diff)
downloadaports-650c08badb6229254f7625ffdbb9e566558e3649.tar.bz2
aports-650c08badb6229254f7625ffdbb9e566558e3649.tar.xz
testing/acl: moved to main
Diffstat (limited to 'testing')
-rw-r--r--testing/acl/APKBUILD54
-rw-r--r--testing/acl/quote-strchr.patch25
2 files changed, 0 insertions, 79 deletions
diff --git a/testing/acl/APKBUILD b/testing/acl/APKBUILD
deleted file mode 100644
index c1b42c6622..0000000000
--- a/testing/acl/APKBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=acl
-pkgver=2.2.49
-pkgrel=0
-pkgdesc="Library for filesystem ACL support"
-url="http://savannah.nongnu.org/projects/acl"
-license="LGPL"
-depends=
-makedepends="attr-dev gzip"
-subpackages="$pkgname-dev $pkgname-doc libacl"
-source="http://mirrors.zerg.biz/nongnu/$pkgname/$pkgname-$pkgver.src.tar.gz
- quote-strchr.patch"
-
-prepare() {
- cd "$srcdir"/acl-$pkgver
- patch -p1 -i "$srcdir"/quote-strchr.patch || return 1
- #libtoolize --force && aclocal -I m4 && autoconf && autoheader
- sed -i \
- -e '/^as_dummy=/s:=":="$PATH$PATH_SEPARATOR:' \
- configure # hack PATH with AC_PATH_PROG
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
- include/builddefs.in \
- || return 1
-}
-
-build() {
- cd "$srcdir"/acl-$pkgver
- unset PLATFORM
- export OPTIMIZER="${CFLAGS}"
- export DEBUG=-DNDEBUG
- CONFIG_SHELL=/bin/sh ./configure --prefix=/usr \
- --libdir=/lib \
- --libexecdir=/usr/lib \
- --disable-gettext \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$srcdir"/acl-$pkgver
- make DIST_ROOT="$pkgdir" install install-lib install-dev
- mv "$pkgdir"/lib/libacl.[al]* "$pkgdir"/usr/lib/
- chown -R root:root "$pkgdir"/*
-}
-
-libacl() {
- mkdir -p "$subpkgdir"/lib
- mv "$pkgdir"/lib/libacl.so.* "$subpkgdir"/lib/
-}
-
-md5sums="181445894cca986da9ae0099d5ce2d08 acl-2.2.49.src.tar.gz
-1bef4f022a068ebfeb3b5363dc6ce174 quote-strchr.patch"
diff --git a/testing/acl/quote-strchr.patch b/testing/acl/quote-strchr.patch
deleted file mode 100644
index d2510da24e..0000000000
--- a/testing/acl/quote-strchr.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 7565e4fcb9209782ed02f3caff246cf5ea816674 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Fri, 8 Jan 2010 21:28:31 -0500
-Subject: [PATCH] quote: pull in string.h for strchr prototype
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- libmisc/quote.c | 1 +
- 1 files changed, 1 insertions(+), 0 deletions(-)
-
-diff --git a/libmisc/quote.c b/libmisc/quote.c
-index f98c887..bf8f9eb 100644
---- a/libmisc/quote.c
-+++ b/libmisc/quote.c
-@@ -20,6 +20,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <ctype.h>
-+#include <string.h>
- #include "misc.h"
-
- const char *quote(const char *str, const char *quote_chars)
---
-1.6.6
-