aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-13 10:55:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-13 10:55:17 +0000
commit9024b25ed4b39092e5b9e8f618793bd9026c84e0 (patch)
tree62e0dfe40015bd539cf841b9639ea9dd5986b489 /testing
parent1b6cdb739c8fe2077f8d7bb7068390c21fa1d9b7 (diff)
downloadaports-9024b25ed4b39092e5b9e8f618793bd9026c84e0.tar.bz2
aports-9024b25ed4b39092e5b9e8f618793bd9026c84e0.tar.xz
testing/mysql: create libmysqlclient subpackage
Diffstat (limited to 'testing')
-rw-r--r--testing/mysql/APKBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/testing/mysql/APKBUILD b/testing/mysql/APKBUILD
index bef9f32d24..95f491c94c 100644
--- a/testing/mysql/APKBUILD
+++ b/testing/mysql/APKBUILD
@@ -10,7 +10,7 @@ makedepends="libtool uclibc++-dev readline-dev openssl-dev"
source="http://sunsite.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.0/${pkgname}-${pkgver}.tar.gz
$pkgname.initd
$pkgname.mycnf"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-test"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-test libmysqlclient"
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -30,6 +30,16 @@ build() {
install -Dm 644 "$startdir"/$pkgname.mycnf $pkgdir/etc/mysql/my.cnf
install -dDo mysql $pkgdir/var/log/mysql
install -dDo mysql $pkgdir/var/run/mysqld
+
+ # we dont want this be pulled in in the make depends resolving but we
+ # want it in the binary package dependency so we add it late.
+ depends="$depends libmysqlclient"
+}
+
+libmysqlclient() {
+ depends="uclibc"
+ mkdir -p "$subpkgdir"/usr/lib/mysql
+ mv "$pkgdir"/usr/lib/mysql/libmysqlclient.so* "$subpkgdir"/usr/lib/mysql
}
test() {