aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-05 14:45:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-05 14:45:27 +0000
commite5ab44d7e4883c6866238ff45489c3477bd9bc76 (patch)
treefc890c0e44940bfd7763b608173472d1d9bdb591 /testing
parente1e098de972546f5fb9194b71bde04cfa12f3c97 (diff)
downloadaports-e5ab44d7e4883c6866238ff45489c3477bd9bc76.tar.bz2
aports-e5ab44d7e4883c6866238ff45489c3477bd9bc76.tar.xz
testing/wine: add patch for dn_skipname
Diffstat (limited to 'testing')
-rw-r--r--testing/wine/APKBUILD5
-rw-r--r--testing/wine/dn_skipname.patch38
2 files changed, 42 insertions, 1 deletions
diff --git a/testing/wine/APKBUILD b/testing/wine/APKBUILD
index 30406ef6af..0f1a2bda52 100644
--- a/testing/wine/APKBUILD
+++ b/testing/wine/APKBUILD
@@ -11,12 +11,14 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
libpng-dev jpeg-dev freetype-dev"
# lcms
source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
+ dn_skipname.patch
libpng14.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- patch -p1 -i "$srcdir"/libpng14.patch
+ patch -p1 -i "$srcdir"/libpng14.patch || return 1
+ patch -p1 -i "$srcdir"/dn_skipname.patch || return 1
}
build() {
@@ -33,4 +35,5 @@ package() {
mkdir -p "$pkgdir"/etc/wine
}
md5sums="ef5947bcb9667b75b8de4a2ce16d0ec2 wine-1.1.38.tar.bz2
+6ebeaa64eddf97be3267db236ce84b71 dn_skipname.patch
51f78b18168d5abd78411e9e66458d55 libpng14.patch"
diff --git a/testing/wine/dn_skipname.patch b/testing/wine/dn_skipname.patch
new file mode 100644
index 0000000000..99ecf83158
--- /dev/null
+++ b/testing/wine/dn_skipname.patch
@@ -0,0 +1,38 @@
+--- ./dlls/dnsapi/ns_parse.c.orig
++++ ./dlls/dnsapi/ns_parse.c
+@@ -69,6 +69,35 @@
+ } while (0)
+
+ /* Public. */
++#ifdef __UCLIBC__
++int
++dn_skipname(const u_char *comp_dn, const u_char *eom)
++{
++ const u_char *cp;
++ int n;
++
++ cp = comp_dn;
++ while (cp < eom && (n = *cp++)) {
++ /*
++ * check for indirection
++ */
++ switch (n & INDIR_MASK) {
++ case 0: /* normal case, n == len */
++ cp += n;
++ continue;
++ case INDIR_MASK: /* indirection */
++ cp++;
++ break;
++ default: /* illegal type */
++ return (-1);
++ }
++ break;
++ }
++ if (cp > eom)
++ return (-1);
++ return (cp - comp_dn);
++}
++#endif
+
+ static int
+ dns_ns_skiprr(const u_char *ptr, const u_char *eom, ns_sect section, int count) {