aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDuane Hughes <duanejevon@gmail.com>2011-01-28 09:30:23 +0000
committerTimo Teräs <timo.teras@iki.fi>2011-02-03 13:14:47 +0200
commit161748dbe02c709b2e833b8dce9eb8200aae3f8b (patch)
treec86c21038930b2ceb17188dacb38b6107dca1abd /testing
parent974ceecd96fbf5b53e9898646e33619f34456222 (diff)
downloadaports-161748dbe02c709b2e833b8dce9eb8200aae3f8b.tar.bz2
aports-161748dbe02c709b2e833b8dce9eb8200aae3f8b.tar.xz
testing/liblockfile: new aport
library files for file locking tools
Diffstat (limited to 'testing')
-rw-r--r--testing/liblockfile/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/liblockfile/APKBUILD b/testing/liblockfile/APKBUILD
new file mode 100644
index 0000000000..6f471cb11d
--- /dev/null
+++ b/testing/liblockfile/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Duane Hughes <duanejevon@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liblockfile
+pkgver=1.08
+pkgrel=0
+pkgdesc="Shared library with NFS-safe locking functions"
+url="http://packages.debian.org/sid/liblockfile1"
+arch="all"
+license="GPL"
+depends=""
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.debian.org/debian/pool/main/libl/liblockfile/${pkgname}_$pkgver.orig.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ install -d "$pkgdir"/usr/include
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/lib
+ install -d "$pkgdir"/usr/share/man
+
+ make -j1 ROOT="$pkgdir" install
+}
+
+md5sums="c24e2dfb4a2aab0263fe5ac1564d305e liblockfile_1.08.orig.tar.gz"