aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-27 14:59:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-27 14:59:51 +0000
commit8fdc7a598b7e305d11e758922a43916ee3e7c145 (patch)
tree9a43b66606788bd370417984662f9aae70c248c8 /testing
parente83a84a337d20424457580ef1bda5b0fec2bd836 (diff)
downloadaports-8fdc7a598b7e305d11e758922a43916ee3e7c145.tar.bz2
aports-8fdc7a598b7e305d11e758922a43916ee3e7c145.tar.xz
testing/shorewall: upgrade to 4.5.18
Diffstat (limited to 'testing')
-rw-r--r--testing/shorewall/APKBUILD40
-rw-r--r--testing/shorewall/shorewall-no-install-T.patch11
-rw-r--r--testing/shorewall/shorewall.initd28
3 files changed, 39 insertions, 40 deletions
diff --git a/testing/shorewall/APKBUILD b/testing/shorewall/APKBUILD
index 4a7ffa1de0..64f77ecdbd 100644
--- a/testing/shorewall/APKBUILD
+++ b/testing/shorewall/APKBUILD
@@ -1,20 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall
-pkgver=4.4.21
-pkgrel=1
-pkgdesc="Shoreline Firewall is an iptables-based firewall for Linux."
+pkgver=4.5.18
+pkgrel=0
+pkgdesc="Core libraries for Shorewall"
url="http://www.shorewall.net/"
arch="noarch"
license="GPL-2"
-depends="iptables iproute2 perl"
-replaces="shorewall-common shorewall-perl"
+depends="shorewall-core perl iptables iproute2"
+# coreutils for install -T
+makedepends="coreutils"
+replaces=""
subpackages="$pkgname-doc"
-source="http://www1.shorewall.net/pub/shorewall/4.4/shorewall-$pkgver/shorewall-$pkgver.tar.bz2
+source="http://www1.shorewall.net/pub/shorewall/${pkgver%.*}/shorewall-$pkgver/$pkgname-$pkgver.tar.bz2
shorewall.initd
- shorewall-no-install-T.patch
"
-_builddir="src/$pkgname-$pkgver"
+_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
local i
cd "$_builddir"
@@ -27,18 +28,19 @@ prepare() {
build() {
cd "$_builddir"
-
- PREFIX="${pkgdir}" ./install.sh || return 1
- install -Dm755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
}
-doc() {
- default_doc
- mkdir -p "$subpkgdir/usr/share/shorewall"
- mv "$pkgdir/usr/share/shorewall/configfiles" \
- "$subpkgdir/usr/share/shorewall/"
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+ rm -f "$pkgdir"/etc/init.d/shorewall
+ install -m755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
}
-md5sums="aac1823063489563330bf5dc57a26487 shorewall-4.4.21.tar.bz2
-3dcf9a43bf7ce03f1d839a97ccf2240d shorewall.initd
-546ca14bae43f5046f193efc884c768b shorewall-no-install-T.patch"
+md5sums="c32a1a14349e9c2c6df32880c08d8d42 shorewall-4.5.18.tar.bz2
+a59c0ec3f299f6a383d33aacbdc83e44 shorewall.initd"
+sha256sums="81bbcb2cc24d0b54769fb153cb472d78e6eed9cdc9f005f1dd70ef2ae9efe131 shorewall-4.5.18.tar.bz2
+ee8cff251a24cc5f9b31e835682f6fc7d9f01625e93c2f9d8c82c859dad09e8e shorewall.initd"
+sha512sums="69857ba9181989a0d0b8ce691e637b313b59d4f5643784e62a801f8d74add0605452011e19e5344aaca97a329fe66980627181e69d9c0fc0625ff23afb192f78 shorewall-4.5.18.tar.bz2
+365819451ee3a412c321eea4d3011c548295f00f9dd2cbb996c84a61be77eae859d568077677f1acad64af2a642028e2ef577a3757239703153b3293232afade shorewall.initd"
diff --git a/testing/shorewall/shorewall-no-install-T.patch b/testing/shorewall/shorewall-no-install-T.patch
deleted file mode 100644
index 09567a5123..0000000000
--- a/testing/shorewall/shorewall-no-install-T.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/shorewall-4.4.21/install.sh
-+++ b/shorewall-4.4.21/install.sh
-@@ -96,7 +96,7 @@
- # INIT is the name of the script in the $DEST directory
- # ARGS is "yes" if we've already parsed an argument
- #
--T="-T"
-+T=
-
- if [ -z "$DEST" ] ; then
- DEST="/etc/init.d"
diff --git a/testing/shorewall/shorewall.initd b/testing/shorewall/shorewall.initd
index 1c5a5f6aee..6dadd30643 100644
--- a/testing/shorewall/shorewall.initd
+++ b/testing/shorewall/shorewall.initd
@@ -1,10 +1,16 @@
#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/files/shorewall.initd,v 1.2 2008/05/04 13:16:40 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall.initd,v 1.4 2013/07/13 14:09:09 constanze Exp $
-extra_started_commands="refresh"
-extra_commands="clear reset check"
+extra_commands="check clear"
+extra_started_commands="refresh reset"
+
+checkconfig() {
+ if [ ! -d /var/lock/subsys ] ; then
+ checkpath -d -m 755 /var/lock/subsys
+ fi
+}
depend() {
need net
@@ -13,23 +19,25 @@ depend() {
}
start() {
- ebegin "Starting firewall"
+ checkconfig
+ ebegin "Starting shorewall"
/sbin/shorewall -f start 1>/dev/null
eend $?
}
stop() {
- ebegin "Stopping firewall"
+ ebegin "Stopping shorewall"
/sbin/shorewall stop 1>/dev/null
eend $?
}
restart() {
+ checkconfig
# shorewall comes with its own control script that includes a
# restart function, so refrain from calling svc_stop/svc_start
# here. Note that this comment is required to fix bug 55576;
# runscript.sh greps this script... (09 Jul 2004 agriffis)
- ebegin "Restarting firewall"
+ ebegin "Restarting shorewall"
/sbin/shorewall status >/dev/null
if [ $? != 0 ] ; then
svc_start
@@ -47,7 +55,7 @@ clear() {
# clear will remove all the rules and bring the system to an unfirewalled
# state. (21 Nov 2004 eldad)
- ebegin "Clearing all firewall rules and setting policy to ACCEPT"
+ ebegin "Clearing all shorewall rules and setting policy to ACCEPT"
/sbin/shorewall clear
eend $?
}
@@ -55,7 +63,7 @@ clear() {
reset() {
# reset the packet and byte counters in the firewall
- ebegin "Resetting the packet and byte counters in the firewall"
+ ebegin "Resetting the packet and byte counters in the shorewall"
/sbin/shorewall reset
eend $?
}
@@ -65,7 +73,7 @@ refresh() {
# interfaces, the black list, traffic control rules and
# ECN control rules
- ebegin "Refreshing firewall rules"
+ ebegin "Refreshing shorewall rules"
/sbin/shorewall refresh
eend $?
}