aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-04-14 10:46:53 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-04-19 15:35:56 +0200
commit294f465d02aac90efd6b0f5a4d82cd4e8ae91b14 (patch)
tree31d951db50709a08e28f418d13e6d594bab4f0c5 /testing
parent14152028a43e2ed3604c7f4272ec27d45d2da943 (diff)
downloadaports-294f465d02aac90efd6b0f5a4d82cd4e8ae91b14.tar.bz2
aports-294f465d02aac90efd6b0f5a4d82cd4e8ae91b14.tar.xz
testing/rtorrent: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/rtorrent/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/rtorrent/APKBUILD b/testing/rtorrent/APKBUILD
new file mode 100644
index 0000000000..9987bf112b
--- /dev/null
+++ b/testing/rtorrent/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=rtorrent
+pkgver=0.8.9
+pkgrel=1
+pkgdesc='Ncurses BitTorrent client based on libTorrent'
+url='http://libtorrent.rakshasa.no/'
+license='GPL'
+arch='all'
+makedepends='libsigc++-dev libtorrent-dev curl-dev xmlrpc-c-dev'
+subpackages="$pkgname-doc"
+source="http://libtorrent.rakshasa.no/downloads/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export LDFLAGS="${LDFLAGS} -lpthread"
+ ./configure \
+ --prefix=/usr \
+ --enable-debug \
+ --with-xmlrpc-c \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+doc() {
+ mkdir -p "$subpkgdir" || return 1
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D doc/faq.xml "${subpkgdir}"/usr/share/doc/rtorrent/faq.xml || return 1
+ install -D doc/rtorrent.1 "${subpkgdir}"/usr/share/man/man1/rtorrent.1 || return 1
+ install -D doc/rtorrent.rc "${subpkgdir}"/usr/share/doc/rtorrent/rtorrent.rc || return 1
+}
+
+md5sums="629247636cb1210663b52dadbd040a6c rtorrent-0.8.9.tar.gz"