aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-04-01 09:52:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-01 14:23:52 +0000
commit842fa5422b604c5422018ab2ced13c108cb0b5fd (patch)
tree5e3c29a51eb54783dc68f63d0044330b9f30412e /testing
parent98448e635adf9a37b6636b5a0e0e912b87e81046 (diff)
downloadaports-842fa5422b604c5422018ab2ced13c108cb0b5fd.tar.bz2
aports-842fa5422b604c5422018ab2ced13c108cb0b5fd.tar.xz
testing/perl-test-mockobject: new aport
perl-test-mockobject: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-test-mockobject/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/perl-test-mockobject/APKBUILD b/testing/perl-test-mockobject/APKBUILD
new file mode 100644
index 0000000000..ff690f4318
--- /dev/null
+++ b/testing/perl-test-mockobject/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Jeff Bilyk <jbilyk@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-test-mockobject
+_realname=Test-MockObject
+pkgver=1.09
+pkgrel=0
+pkgdesc="Perl Mock part of an object or class"
+url="http://search.cpan.org/~chromatic/"
+arch="x86 x86_64"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages=""
+source="http://search.cpan.org/CPAN/authors/id/C/CH/CHROMATIC/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd $_builddir
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd $_builddir
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+
+}
+
+md5sums="3c9c2842d40fa8c389563c227804d7d8 Test-MockObject-1.09.tar.gz"