aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-02-25 08:00:40 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-25 14:43:30 +0000
commit495276ab55d55bff4af29a116d2085ad58e21d73 (patch)
tree6fd6d76a2b91654ac2fb3a9f54fe615e011b0108 /testing
parenteaf19f88756e63006252a9d72a4e1af3ae4613e4 (diff)
downloadaports-495276ab55d55bff4af29a116d2085ad58e21d73.tar.bz2
aports-495276ab55d55bff4af29a116d2085ad58e21d73.tar.xz
main/numactl: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/numactl/APKBUILD55
-rw-r--r--testing/numactl/musl.patch21
2 files changed, 0 insertions, 76 deletions
diff --git a/testing/numactl/APKBUILD b/testing/numactl/APKBUILD
deleted file mode 100644
index ccfe62950e..0000000000
--- a/testing/numactl/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
-pkgname=numactl
-pkgver=2.0.12
-pkgrel=2
-pkgdesc="Simple NUMA policy support"
-url="https://github.com/numactl/numactl"
-# ARM lacks the __NR_migrate_pages syscall
-arch="all !armhf !armv7"
-license="GPL-2.0 LGPL-2.0"
-makedepends="autoconf automake libtool linux-headers"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-case "$CARCH" in
- s390x) options="!check";; # FAIL: distance test
-esac
-source="$pkgname-$pkgver.tar.gz::https://github.com/numactl/$pkgname/archive/v$pkgver.tar.gz
- musl.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- default_prepare
-
- cd "$builddir"
- ./autogen.sh
-}
-
-check() {
- cd "$builddir"
- make check VERBOSE=1 TESTS='test/distance test/nodemap test/tbitmap'
-}
-
-build() {
- cd "$builddir"
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-
- # provided by linux man-pages
- rm -r "$pkgdir"/usr/share/man/man2
-}
-
-tools() {
- pkgdesc="NUMA policy control tools"
-
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr
-}
-
-sha512sums="3814efd924d1c9152a30f6ae5b665afc20648226cd475d72b933c0ec4f30249af4e25110de17f144734b787ed765644dca09a657219806ab5c9c550abd45bf8e numactl-2.0.12.tar.gz
-c24affa5a8a8ea83d7f0ee384dc0629e17a5c4201357132f770f894ad4236772116d96d8389d54fb99095af40d1ccbffc3170b5fb9cc88cfca39179f50bee9c9 musl.patch"
diff --git a/testing/numactl/musl.patch b/testing/numactl/musl.patch
deleted file mode 100644
index 009233f630..0000000000
--- a/testing/numactl/musl.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- numactl-2.0.11/syscall.c.orig
-+++ numactl-2.0.11/syscall.c
-@@ -115,14 +115,16 @@
-
- #endif
-
--#if defined(__GLIBC__) && __GLIBC_PREREQ(2, 11)
-+#if defined(__GLIBC__)
-+# if __GLIBC_PREREQ(2,11)
-
- /* glibc 2.11 seems to have working 6 argument sycall. Use the
- glibc supplied syscall in this case.
- The version cut-off is rather arbitary and could be probably
- earlier. */
-
--#define syscall6 syscall
-+# define syscall6 syscall
-+#endif
- #elif defined(__x86_64__)
- /* 6 argument calls on x86-64 are often buggy in both glibc and
- asm/unistd.h. Add a working version here. */