aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-17 11:01:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-17 11:01:28 +0000
commit70b7e56d8066fcc8c2a398f536fcff0bac303bb1 (patch)
treec077b0acf5b7811c49cbb42a81ecc517db426348 /testing
parent6fb12558b614640e2cc65e800031654323427a0b (diff)
downloadaports-70b7e56d8066fcc8c2a398f536fcff0bac303bb1.tar.bz2
aports-70b7e56d8066fcc8c2a398f536fcff0bac303bb1.tar.xz
dahdi-linux-vserver: upgrade to 2.6.32 kernel
Diffstat (limited to 'testing')
-rw-r--r--testing/dahdi-linux-vserver/APKBUILD14
-rw-r--r--testing/dahdi-linux-vserver/dahdi-2.2.0.2-driver_data-2.6.32.patch84
-rw-r--r--testing/dahdi-linux-vserver/dahdi-2.2.0.2-gcc44-hack.patch27
-rw-r--r--testing/dahdi-linux-vserver/dahdi-2.2.0.2-includes.patch100
-rw-r--r--testing/dahdi-linux-vserver/dahdi-zaphfc.patch3
5 files changed, 224 insertions, 4 deletions
diff --git a/testing/dahdi-linux-vserver/APKBUILD b/testing/dahdi-linux-vserver/APKBUILD
index 14c26a0078..3d7542cb07 100644
--- a/testing/dahdi-linux-vserver/APKBUILD
+++ b/testing/dahdi-linux-vserver/APKBUILD
@@ -10,12 +10,14 @@ fi
_kernelver="$pkgver-r$pkgrel"
_abi_release=${pkgver}-${_flavor}
+_kpkgrel=$pkgrel
_realname=dahdi-linux
pkgname=${_realname}-${_flavor}
pkgver=$pkgver
_dahdiver=2.2.0.2
-pkgrel=0
+_mypkgrel=0
+pkgrel=$(( $_kpkgrel + $_mypkgrel ))
pkgdesc="Digium Asterisk Hardware Device Interface drivers $_dahdiver"
url="http://www.asterisk.org"
license="GPL"
@@ -32,6 +34,9 @@ source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realna
zaphfc-dahdi-flortz.diff
dahdi-linux-2.2.0-hfc-4s.patch
dahdi-2.6.31.patch
+ dahdi-2.2.0.2-driver_data-2.6.32.patch
+ dahdi-2.2.0.2-includes.patch
+ dahdi-2.2.0.2-gcc44-hack.patch
"
prepare() {
@@ -70,7 +75,10 @@ dev() {
md5sums="1f932729ad28f2f028afcf2cc5ccf7ba dahdi-linux-2.2.0.2.tar.gz
c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch
4b41a82ff390ac64c08092c5a3eab6a8 dahdi-bri_dchan.patch
-a822c092f0548cd13f5e8d8cba053af6 dahdi-zaphfc.patch
+3be420539f5e2e2b94a1bf3d711ec630 dahdi-zaphfc.patch
291c5c44c86ab02443a742415461ddca zaphfc-dahdi-flortz.diff
68dfe17a49cca15ae439fd83f4ccfbc5 dahdi-linux-2.2.0-hfc-4s.patch
-bd5e7457ee8f37c10ed7ec383995e4fa dahdi-2.6.31.patch"
+bd5e7457ee8f37c10ed7ec383995e4fa dahdi-2.6.31.patch
+7f9452ef37385e03e05147081d6951a1 dahdi-2.2.0.2-driver_data-2.6.32.patch
+6c208d6346a3668cea900baa45298f6a dahdi-2.2.0.2-includes.patch
+eeb4b2870d23d7c020cd99b5b1a633e9 dahdi-2.2.0.2-gcc44-hack.patch"
diff --git a/testing/dahdi-linux-vserver/dahdi-2.2.0.2-driver_data-2.6.32.patch b/testing/dahdi-linux-vserver/dahdi-2.2.0.2-driver_data-2.6.32.patch
new file mode 100644
index 0000000000..3085218c09
--- /dev/null
+++ b/testing/dahdi-linux-vserver/dahdi-2.2.0.2-driver_data-2.6.32.patch
@@ -0,0 +1,84 @@
+diff -uNr dahdi-linux-2.2.0.2.ORIg/drivers/dahdi/xpp/xbus-sysfs.c dahdi-linux-2.2.0.2/drivers/dahdi/xpp/xbus-sysfs.c
+--- dahdi-linux-2.2.0.2.ORIg/drivers/dahdi/xpp/xbus-sysfs.c 2009-10-22 18:04:47.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/xpp/xbus-sysfs.c 2009-10-22 18:05:54.000000000 +0100
+@@ -707,7 +707,11 @@
+ dev->parent = &xbus->astribank;
+ dev_set_name(dev, "%02d:%1x:%1x", xbus->num, xpd->addr.unit,
+ xpd->addr.subunit);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
++ dev_set_drvdata(dev, xpd);
++#else
+ dev->driver_data = xpd;
++#endif
+ dev->release = xpd_release;
+ ret = device_register(dev);
+ if(ret) {
+@@ -728,11 +732,21 @@
+ BUG_ON(!xbus);
+ XPD_DBG(DEVICES, xpd, "SYSFS\n");
+ dev = &xpd->xpd_dev;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
++ if(!dev_get_drvdata(dev))
++ return;
++ BUG_ON(dev_get_drvdata(dev) != xpd);
++#else
+ if(!dev->driver_data)
+ return;
+ BUG_ON(dev->driver_data != xpd);
++#endif
+ device_unregister(dev);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
++ dev_set_drvdata(dev, NULL);
++#else
+ dev->driver_data = NULL;
++#endif
+ }
+
+ /*--------- Sysfs Device handling ----*/
+@@ -746,9 +760,15 @@
+ astribank = &xbus->astribank;
+ BUG_ON(!astribank);
+ sysfs_remove_link(&astribank->kobj, "transport");
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
++ if(!dev_get_drvdata(astribank))
++ return;
++ BUG_ON(dev_get_drvdata(astribank) != xbus);
++#else
+ if(!astribank->driver_data)
+ return;
+ BUG_ON(astribank->driver_data != xbus);
++#endif
+ device_unregister(&xbus->astribank);
+ }
+
+@@ -764,18 +784,30 @@
+ astribank->bus = &toplevel_bus_type;
+ astribank->parent = xbus->transport.transport_device;
+ dev_set_name(astribank, "xbus-%02d", xbus->num);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
++ dev_set_drvdata(astribank, xbus);
++#else
+ astribank->driver_data = xbus;
++#endif
+ astribank->release = astribank_release;
+ ret = device_register(astribank);
+ if(ret) {
+ XBUS_ERR(xbus, "%s: device_register failed: %d\n", __FUNCTION__, ret);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
++ dev_set_drvdata(astribank, NULL);
++#else
+ astribank->driver_data = NULL;
++#endif
+ goto out;
+ }
+ ret = sysfs_create_link(&astribank->kobj, &astribank->parent->kobj, "transport");
+ if(ret < 0) {
+ XBUS_ERR(xbus, "%s: sysfs_create_link failed: %d\n", __FUNCTION__, ret);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
++ dev_set_drvdata(astribank, NULL);
++#else
+ astribank->driver_data = NULL;
++#endif
+ goto out;
+ }
+ out:
diff --git a/testing/dahdi-linux-vserver/dahdi-2.2.0.2-gcc44-hack.patch b/testing/dahdi-linux-vserver/dahdi-2.2.0.2-gcc44-hack.patch
new file mode 100644
index 0000000000..d647a1f9be
--- /dev/null
+++ b/testing/dahdi-linux-vserver/dahdi-2.2.0.2-gcc44-hack.patch
@@ -0,0 +1,27 @@
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/xpp/xpp_dahdi.c dahdi-linux-2.2.0.2/drivers/dahdi/xpp/xpp_dahdi.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/xpp/xpp_dahdi.c 2009-10-22 18:52:23.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/xpp/xpp_dahdi.c 2009-10-22 18:52:55.000000000 +0100
+@@ -865,9 +865,11 @@
+ #endif
+ spin_lock_irqsave(&xbus->lock, flags);
+ atomic_inc(&xpd->open_counter);
++/*
+ LINE_DBG(DEVICES, xpd, pos, "%s[%d]: open_counter=%d\n",
+ current->comm, current->pid,
+ atomic_read(&xpd->open_counter));
++*/
+ spin_unlock_irqrestore(&xbus->lock, flags);
+ if(xpd->xops->card_open)
+ xpd->xops->card_open(xpd, pos);
+@@ -885,9 +887,11 @@
+ spin_unlock_irqrestore(&xbus->lock, flags);
+ if(xpd->xops->card_close)
+ xpd->xops->card_close(xpd, pos);
++/*
+ LINE_DBG(DEVICES, xpd, pos, "%s[%d]: open_counter=%d\n",
+ current->comm, current->pid,
+ atomic_read(&xpd->open_counter));
++*/
+ atomic_dec(&xpd->open_counter); /* from xpp_open() */
+ put_xpd(__FUNCTION__, xpd); /* from xpp_open() */
+ return 0;
diff --git a/testing/dahdi-linux-vserver/dahdi-2.2.0.2-includes.patch b/testing/dahdi-linux-vserver/dahdi-2.2.0.2-includes.patch
new file mode 100644
index 0000000000..5451bc6915
--- /dev/null
+++ b/testing/dahdi-linux-vserver/dahdi-2.2.0.2-includes.patch
@@ -0,0 +1,100 @@
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/dahdi-base.c dahdi-linux-2.2.0.2/drivers/dahdi/dahdi-base.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/dahdi-base.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/dahdi-base.c 2009-10-22 17:14:49.000000000 +0100
+@@ -46,6 +46,7 @@
+ #include <linux/kmod.h>
+ #include <linux/moduleparam.h>
+ #include <linux/list.h>
++#include <linux/sched.h>
+
+ #include <linux/ppp_defs.h>
+
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/pciradio.c dahdi-linux-2.2.0.2/drivers/dahdi/pciradio.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/pciradio.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/pciradio.c 2009-10-22 17:14:49.000000000 +0100
+@@ -51,6 +51,7 @@
+ #include <linux/pci.h>
+ #include <linux/interrupt.h>
+ #include <linux/moduleparam.h>
++#include <linux/sched.h>
+ #include <asm/io.h>
+ #include <asm/delay.h>
+
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/voicebus/voicebus.c dahdi-linux-2.2.0.2/drivers/dahdi/voicebus/voicebus.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/voicebus/voicebus.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/voicebus/voicebus.c 2009-10-22 17:16:44.000000000 +0100
+@@ -35,6 +35,7 @@
+ #include <linux/interrupt.h>
+ #include <linux/timer.h>
+ #include <linux/module.h>
++#include <linux/sched.h>
+
+ #include <dahdi/kernel.h>
+ #include "voicebus.h"
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wcfxo.c dahdi-linux-2.2.0.2/drivers/dahdi/wcfxo.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wcfxo.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/wcfxo.c 2009-10-22 17:14:49.000000000 +0100
+@@ -30,6 +30,7 @@
+ #include <linux/usb.h>
+ #include <linux/errno.h>
+ #include <linux/pci.h>
++#include <linux/sched.h>
+ #include <asm/io.h>
+ #include <linux/moduleparam.h>
+
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wct1xxp.c dahdi-linux-2.2.0.2/drivers/dahdi/wct1xxp.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wct1xxp.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/wct1xxp.c 2009-10-22 17:14:49.000000000 +0100
+@@ -33,6 +33,7 @@
+ #include <linux/pci.h>
+ #include <linux/spinlock.h>
+ #include <linux/moduleparam.h>
++#include <linux/sched.h>
+
+ #include <dahdi/kernel.h>
+
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wctdm24xxp/base.c dahdi-linux-2.2.0.2/drivers/dahdi/wctdm24xxp/base.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wctdm24xxp/base.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/wctdm24xxp/base.c 2009-10-22 17:14:49.000000000 +0100
+@@ -45,6 +45,7 @@
+ #include <linux/workqueue.h>
+ #include <linux/delay.h>
+ #include <linux/moduleparam.h>
++#include <linux/sched.h>
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)
+ #include <linux/semaphore.h>
+ #else
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wctdm.c dahdi-linux-2.2.0.2/drivers/dahdi/wctdm.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wctdm.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/wctdm.c 2009-10-22 17:14:49.000000000 +0100
+@@ -31,6 +31,8 @@
+ #include <linux/pci.h>
+ #include <linux/interrupt.h>
+ #include <linux/moduleparam.h>
++#include <linux/sched.h>
++
+ #include <asm/io.h>
+ #include "proslic.h"
+
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wcte11xp.c dahdi-linux-2.2.0.2/drivers/dahdi/wcte11xp.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/wcte11xp.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/wcte11xp.c 2009-10-22 17:14:49.000000000 +0100
+@@ -32,6 +32,7 @@
+ #include <linux/pci.h>
+ #include <linux/spinlock.h>
+ #include <linux/moduleparam.h>
++#include <linux/sched.h>
+
+ #include <dahdi/kernel.h>
+
+diff -uNr dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/xpp/xbus-core.c dahdi-linux-2.2.0.2/drivers/dahdi/xpp/xbus-core.c
+--- dahdi-linux-2.2.0.2.ORIG/drivers/dahdi/xpp/xbus-core.c 2009-10-22 17:14:40.000000000 +0100
++++ dahdi-linux-2.2.0.2/drivers/dahdi/xpp/xbus-core.c 2009-10-22 17:16:10.000000000 +0100
+@@ -35,6 +35,7 @@
+ #include <linux/workqueue.h>
+ #include <linux/device.h>
+ #include <linux/delay.h> /* for msleep() to debug */
++#include <linux/sched.h>
+ #include "xpd.h"
+ #include "xpp_dahdi.h"
+ #include "xbus-core.h"
diff --git a/testing/dahdi-linux-vserver/dahdi-zaphfc.patch b/testing/dahdi-linux-vserver/dahdi-zaphfc.patch
index b711c07ff9..735d1c5a3f 100644
--- a/testing/dahdi-linux-vserver/dahdi-zaphfc.patch
+++ b/testing/dahdi-linux-vserver/dahdi-zaphfc.patch
@@ -2,7 +2,7 @@ Index: dahdi-linux-2.1.0/drivers/dahdi/zaphfc.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ dahdi-linux-2.1.0/drivers/dahdi/zaphfc.c 2008-12-10 12:46:14.000000000 +0200
-@@ -0,0 +1,1129 @@
+@@ -0,0 +1,1130 @@
+/*
+ * zaphfc.c - Zaptel driver for HFC-S PCI A based ISDN BRI cards
+ *
@@ -29,6 +29,7 @@ Index: dahdi-linux-2.1.0/drivers/dahdi/zaphfc.c
+#include <linux/init.h>
+#include <linux/interrupt.h>
+#include <linux/delay.h>
++#include <linux/sched.h>
+#include <dahdi/kernel.h>
+#include "zaphfc.h"
+