aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorStefan stutz <stutz@pm.me>2019-01-17 16:08:35 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-02-18 16:51:33 +0000
commit79deec876eec167af1c28c40d63eff9afa1def97 (patch)
treee446d838de5cf659bdc989950f7582d2e05f44bf /testing
parent836b364d6b72244c0578583fdb9751c299061d48 (diff)
downloadaports-79deec876eec167af1c28c40d63eff9afa1def97.tar.bz2
aports-79deec876eec167af1c28c40d63eff9afa1def97.tar.xz
testing/mpdecimal: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/mpdecimal/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/mpdecimal/APKBUILD b/testing/mpdecimal/APKBUILD
new file mode 100644
index 0000000000..92544f17bb
--- /dev/null
+++ b/testing/mpdecimal/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Stefan Stutz <stutz@pm.me>
+# Maintainer: Stefan Stutz <stutz@pm.me>
+pkgname=mpdecimal
+pkgver=2.4.2
+pkgrel=0
+pkgdesc="A complete implementation of the General Decimal Arithmetic Specification"
+url="http://www.bytereef.org/mpdecimal/index.html"
+arch="all"
+license="BSD"
+subpackages="$pkgname-doc"
+source="http://www.bytereef.org/software/mpdecimal/releases/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+sha512sums="eb18ad53b81b93c469db4d915bbb3fae21b36ad82a88e01fef3a6946ac5f50b54376e259a5ecbe23836f1efd59d226b942ecdee87eaba7f9e75cdcaaa9499ef7 mpdecimal-2.4.2.tar.gz"