aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-02-27 19:22:50 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-02-28 07:13:48 +0000
commit8c9bc3ab93115dd9c3193f7bd0598d00329fa74d (patch)
treed57e1a28bc909af70cf36c5386a07e27eb7ef808 /testing
parentf92187a86f4dae98f0e171cf44ef7618e88d2f86 (diff)
downloadaports-8c9bc3ab93115dd9c3193f7bd0598d00329fa74d.tar.bz2
aports-8c9bc3ab93115dd9c3193f7bd0598d00329fa74d.tar.xz
testing/ell: new aport
dependency for iwd
Diffstat (limited to 'testing')
-rw-r--r--testing/ell/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/ell/APKBUILD b/testing/ell/APKBUILD
new file mode 100644
index 0000000000..684119dcec
--- /dev/null
+++ b/testing/ell/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=ell
+pkgver=0.17
+pkgrel=0
+pkgdesc="Linux library for embedded development"
+url="https://01.org/ell"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="glib-dev"
+options="!check" #Currently some tests fail. This is an environmental problem to test
+subpackages="$pkgname-dev"
+source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/$pkgname-${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-${pkgver}"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-glib
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="2f35214283bc2b0d17b27a096a0457679747966cad284e3bc581b9414909f98eb3bae9c33d30e62992dccf2331886af505a07e6a73df4c54d3ac476f6791da56 ell-0.17.tar.gz"