aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-07-03 09:07:07 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-03 09:07:07 +0000
commit925deab8814d5aca05091f621e57426c698eafe9 (patch)
tree41634ff1256bc25fd89b0e71b0bb21718e5bddee /testing
parent7acdbc68ea9e9c3736761e763f7d259ab69f91c1 (diff)
downloadaports-925deab8814d5aca05091f621e57426c698eafe9.tar.bz2
aports-925deab8814d5aca05091f621e57426c698eafe9.tar.xz
community/libnsl: moved from testing, added check() function
Diffstat (limited to 'testing')
-rw-r--r--testing/libnsl/APKBUILD46
-rw-r--r--testing/libnsl/cdefs.patch30
-rw-r--r--testing/libnsl/nis_h.patch45
3 files changed, 0 insertions, 121 deletions
diff --git a/testing/libnsl/APKBUILD b/testing/libnsl/APKBUILD
deleted file mode 100644
index 8ccb76087d..0000000000
--- a/testing/libnsl/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Maintainer: Valery Kartel <valery.kartel@gmail.com>
-pkgname=libnsl
-pkgver=1.0.5
-pkgrel=1
-pkgdesc="Public client interface for NIS(YP) and NIS+ in a IPv6 ready version"
-url="https://github.com/thkukuk/libnsl"
-arch="all"
-license="LGPL2+"
-options="!check"
-depends=
-depends_dev=
-makedepends="autoconf automake libtool libc-dev gettext-dev libtirpc-dev"
-install=
-subpackages="$pkgname-dev"
-source="https://github.com/thkukuk/$pkgname/archive/$pkgname-$pkgver.tar.gz
- nis_h.patch
- cdefs.patch
- "
-builddir="$srcdir/$pkgname-$pkgname-$pkgver"
-
-prepare() {
- default_prepare || return 1
-
- cd "$builddir"
- ./autogen.sh
-}
-
-build() {
- cd "$builddir"
- ./configure LIBS="-lintl" \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- || return 1
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="ce0423042d372a9f800738480d222164e7ad2e09c9efa80d4845b9a06b78f478c395a65a4c175dd708d01f0bb9be9514526c44df48990221fd6d28c785767c49 libnsl-1.0.5.tar.gz
-6c555a8efab74eb55e0aaa2bef97d8ab14e382afaec59b99b47ff6f9abf4d33881f20543f88d41beabddfe934c368c4340c7254354fa9680120c0cc021df3468 nis_h.patch
-a0a761a50d611207cae4ad8e46b5b61fed498fe8c094841de99a550b43a0f95febcbccfafcd9568622abeb6e822f4bd9a21ecb261cb86fd8f4e601ce60749a9d cdefs.patch"
diff --git a/testing/libnsl/cdefs.patch b/testing/libnsl/cdefs.patch
deleted file mode 100644
index dbbe800a34..0000000000
--- a/testing/libnsl/cdefs.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/src/rpcsvc/nislib.h
-+++ b/src/rpcsvc/nislib.h
-@@ -19,6 +19,7 @@
- #ifndef __RPCSVC_NISLIB_H__
- #define __RPCSVC_NISLIB_H__
-
-+#include <sys/cdefs.h>
- #include <features.h>
-
- __BEGIN_DECLS
---- a/src/rpcsvc/ypclnt.h
-+++ b/src/rpcsvc/ypclnt.h
-@@ -20,6 +20,7 @@
- #ifndef __RPCSVC_YPCLNT_H__
- #define __RPCSVC_YPCLNT_H__
-
-+#include <sys/cdefs.h>
- #include <features.h>
-
- /* Some defines */
---- a/src/rpcsvc/ypupd.h
-+++ b/src/rpcsvc/ypupd.h
-@@ -33,6 +33,7 @@
- #ifndef __RPCSVC_YPUPD_H__
- #define __RPCSVC_YPUPD_H__
-
-+#include <sys/cdefs.h>
- #include <features.h>
-
- #include <rpc/rpc.h>
diff --git a/testing/libnsl/nis_h.patch b/testing/libnsl/nis_h.patch
deleted file mode 100644
index 199259df2e..0000000000
--- a/testing/libnsl/nis_h.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/src/rpcsvc/nis.h
-+++ b/src/rpcsvc/nis.h
-@@ -32,6 +32,7 @@
- #ifndef _RPCSVC_NIS_H
- #define _RPCSVC_NIS_H 1
-
-+#include <sys/cdefs.h>
- #include <features.h>
- #include <rpc/rpc.h>
- #include <rpcsvc/nis_tags.h>
-@@ -56,6 +57,34 @@
- * <kukuk@suse.de>
- */
-
-+#ifndef rawmemchr
-+#define rawmemchr(s,c) memchr((s),(size_t)-1,(c))
-+#endif
-+
-+#ifndef __asprintf
-+#define __asprintf asprintf
-+#endif
-+
-+#ifndef __mempcpy
-+#define __mempcpy mempcpy
-+#endif
-+
-+#ifndef __strtok_r
-+#define __strtok_r strtok_r
-+#endif
-+
-+#ifndef __always_inline
-+#define __always_inline __attribute__((__always_inline__))
-+#endif
-+
-+#ifndef TEMP_FAILURE_RETRY
-+#define TEMP_FAILURE_RETRY(exp) ({ \
-+typeof (exp) _rc; \
-+ do { \
-+ _rc = (exp); \
-+ } while (_rc == -1 && errno == EINTR); \
-+ _rc; })
-+#endif
-
- #ifndef __nis_object_h
- #define __nis_object_h