aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-17 22:44:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-17 22:44:38 +0200
commitc6ab94ec8f08ab8fd7e7943b6785935d63e9beeb (patch)
treee5d467282a733001c0393015984300bbcdd6f211 /testing
parentc7c00f22fa96aaaed4ef025e8381b44642306281 (diff)
downloadaports-c6ab94ec8f08ab8fd7e7943b6785935d63e9beeb.tar.bz2
aports-c6ab94ec8f08ab8fd7e7943b6785935d63e9beeb.tar.xz
testing/pv: improve abuild
Diffstat (limited to 'testing')
-rw-r--r--testing/pv/APKBUILD20
1 files changed, 4 insertions, 16 deletions
diff --git a/testing/pv/APKBUILD b/testing/pv/APKBUILD
index 1a6820c24f..da1f9ee9b6 100644
--- a/testing/pv/APKBUILD
+++ b/testing/pv/APKBUILD
@@ -6,27 +6,15 @@ pkgrel=0
pkgdesc="CLI tool for monitoring the progress of data through a pipeline"
url="http://www.ivarch.com/programs/pv.shtml"
arch="all"
-license="Artistic 2.0"
+license="Artistic-2.0"
depends=""
-depends_dev=""
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-doc"
source="http://www.ivarch.com/programs/sources/pv-$pkgver.tar.bz2"
-
-_builddir="$srcdir"/pv-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -40,7 +28,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}