aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-23 07:55:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-23 07:55:52 +0000
commitdab6ddc7f8703449026421f6f9831609d0bee490 (patch)
treeae34757ee3db68963bdf5c4de55f5e71430a0e18 /testing
parent103e83f6a967f4e39553f15d4ff947de877f877d (diff)
downloadaports-dab6ddc7f8703449026421f6f9831609d0bee490.tar.bz2
aports-dab6ddc7f8703449026421f6f9831609d0bee490.tar.xz
testing/py-urlgrabber: new aport
python module for fetching files http://urlgrabber.baseurl.org/
Diffstat (limited to 'testing')
-rw-r--r--testing/py-urlgrabber/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py-urlgrabber/APKBUILD b/testing/py-urlgrabber/APKBUILD
new file mode 100644
index 0000000000..3d812a5b8a
--- /dev/null
+++ b/testing/py-urlgrabber/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-urlgrabber
+pkgver=3.9.1
+pkgrel=0
+pkgdesc="python module for fetching files"
+url="http://urlgrabber.baseurl.org/"
+arch="noarch"
+license="LGPL"
+depends="python py-curl"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://urlgrabber.baseurl.org/download/urlgrabber-$pkgver.tar.gz"
+
+_builddir="$srcdir"/urlgrabber-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="00c8359bf71062d0946bacea521f80b4 urlgrabber-3.9.1.tar.gz"