aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-06 12:18:18 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-06 12:18:48 +0200
commit4366f647d1a4b463a916656965f84081f3b38bfa (patch)
tree7400418b100908928a3949ade704c98c1af42bea /testing
parent07dc7e7b57a38f7a8ca41f71453e478d46380172 (diff)
downloadaports-4366f647d1a4b463a916656965f84081f3b38bfa.tar.bz2
aports-4366f647d1a4b463a916656965f84081f3b38bfa.tar.xz
testing/pgimportdoc: new aport
https://github.com/okbob/pgimportdoc CLI tool for import XML, TEXT and BYTEA documents to PostgreSQL
Diffstat (limited to 'testing')
-rw-r--r--testing/pgimportdoc/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/pgimportdoc/APKBUILD b/testing/pgimportdoc/APKBUILD
new file mode 100644
index 0000000000..8e77418bfe
--- /dev/null
+++ b/testing/pgimportdoc/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pgimportdoc
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="CLI tool for import XML, TEXT and BYTEA documents to PostgreSQL"
+url="https://github.com/okbob/pgimportdoc"
+arch="all"
+license="BSD"
+makedepends="libedit-dev libxml2-dev postgresql-dev zlib-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/okbob/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make USE_PGXS=1 all
+}
+
+check() {
+ cd "$builddir"
+ ./pgimportdoc -V
+}
+
+package() {
+ cd "$builddir"
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="f4e0cba9ec81bebb8530a290528c238c8aa16730f6adc89843db75e143e66262b72ac791e943df9d5897eea90c29638b161d7ca08793692d1b5e7d2c1d99286c pgimportdoc-0.1.2.tar.gz"