aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 13:37:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 14:32:12 -0300
commit811a33d4c1caac67e4c4b6ac76023a767c37350d (patch)
tree0e9f1aa52305530b4f0d858398d4f408fa6be37c /testing
parent157eabd9d81ca846ac8f865fbacc0f2fd040721d (diff)
downloadaports-811a33d4c1caac67e4c4b6ac76023a767c37350d.tar.bz2
aports-811a33d4c1caac67e4c4b6ac76023a767c37350d.tar.xz
testing/spirv-headers: new aport
https://github.com/KhronosGroup/SPIRV-Headers Machine-readable files for the SPIR-V Registry
Diffstat (limited to 'testing')
-rw-r--r--testing/spirv-headers/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/spirv-headers/APKBUILD b/testing/spirv-headers/APKBUILD
new file mode 100644
index 0000000000..121cd63f9f
--- /dev/null
+++ b/testing/spirv-headers/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=spirv-headers
+_pkgname=SPIRV-Headers
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="Machine-readable files for the SPIR-V Registry"
+options="!check" # No testsuite
+url="https://github.com/KhronosGroup/SPIRV-Headers"
+arch="noarch"
+license="GPL-3.0-or-later"
+makedepends="cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/KhronosGroup/$_pkgname/archive/${pkgver}.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ ${CMAKE_CROSSOPTS} .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="def34baa2a67128126d0918445b757e2b67a5cf012f6ca4f9a671741e4b1bf6939a7ebd114f7741bcd19bd6c22d0c5dc46adc8ac62ec474164278858c2e65dcf spirv-headers-1.4.1.tar.gz"