aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-02-01 19:27:36 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-02-01 19:27:36 +0200
commitc4c677729d65fda515f2289c5e0d628f9892ee83 (patch)
tree8830d49dd0221e091633e4e1db66a5482e2e5f57 /testing
parentb8247e51c4ddeddd22cfb3344d82aca4f4b56b21 (diff)
downloadaports-c4c677729d65fda515f2289c5e0d628f9892ee83.tar.bz2
aports-c4c677729d65fda515f2289c5e0d628f9892ee83.tar.xz
testing/vlc: add -fpermissive to build against zlib 1.2.6
Diffstat (limited to 'testing')
-rw-r--r--testing/vlc/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/vlc/APKBUILD b/testing/vlc/APKBUILD
index 22b1de77ee..09d301181c 100644
--- a/testing/vlc/APKBUILD
+++ b/testing/vlc/APKBUILD
@@ -97,7 +97,9 @@ build ()
cd "$_builddir"
sed -i -e 's:/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf:/usr/share/fonts/TTF/DejaVuSerif-Bold.ttf:' modules/misc/freetype.c
- export CFLAGS="$CFLAGS -D_GNU_SOURCE"
+ # -fpermissive is needed due to zlib 1.2.6 changing
+ # void* to gzFile on gz*() functions
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE -fpermissive"
./configure --prefix=/usr \
--disable-mmx \