aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-30 00:12:32 +0200
committerprspkt <prspkt@protonmail.com>2019-03-30 00:12:32 +0200
commitcfee84f585419a553d461232112c9112f4de8637 (patch)
tree27332538e22c2754d8ba1c52feda5c3ec1644731 /testing
parentd409fa08b2ebd3bef2a2c9de1132b8785a7ef254 (diff)
downloadaports-cfee84f585419a553d461232112c9112f4de8637.tar.bz2
aports-cfee84f585419a553d461232112c9112f4de8637.tar.xz
testing/py-ansi2html: upgrade to python3
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-ansi2html/APKBUILD (renamed from testing/py-ansi2html/APKBUILD)12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/py-ansi2html/APKBUILD b/testing/py3-ansi2html/APKBUILD
index af152cd7c5..b9f6db1b77 100644
--- a/testing/py-ansi2html/APKBUILD
+++ b/testing/py3-ansi2html/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-ansi2html
+pkgname=py3-ansi2html
_pkgname=ansi2html
pkgver=1.3.0
pkgrel=0
@@ -8,9 +8,11 @@ pkgdesc="Convert text with ANSI color codes to HTML"
url="http://github.com/ralphbean/ansi2html/"
arch="noarch"
license="GPL-3.0-or-later"
-depends="python2 py-setuptools py-six"
+provides="py-ansi2html" # for backwards compatibility
+replaces="py-ansi2html=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3 py3-setuptools py3-six"
depends_dev=""
-makedepends="python2-dev"
+makedepends="python3-dev"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -19,12 +21,12 @@ builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
sha512sums="73d1b3431e22146c4fe18fef4b05413231d79d627c396d67528d0aa1ab07a7ef4bcfeff56829b85d9fe9ad508599b782318911f7b10d6b9a1bc98780e31389d7 ansi2html-1.3.0.tar.gz"