aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-05-02 12:37:22 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-05-02 12:37:22 +0000
commite9f086134201a0d0a6a0ed16997cb7dc0925090c (patch)
treee5d0042d717972206ee173d07e86a863dc8a670d /testing
parente2786ac703bf4773fcfc72dde7bd11c842cb4c2f (diff)
downloadaports-e9f086134201a0d0a6a0ed16997cb7dc0925090c.tar.bz2
aports-e9f086134201a0d0a6a0ed16997cb7dc0925090c.tar.xz
testing/lua5.3-lxc: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/lua5.3-lxc/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/lua5.3-lxc/APKBUILD b/testing/lua5.3-lxc/APKBUILD
new file mode 100644
index 0000000000..2a7ef99783
--- /dev/null
+++ b/testing/lua5.3-lxc/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=lua5.3-lxc
+_pkgname=lua-lxc
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="LUA binding for liblxc"
+url="https://github.com/lxc/lua-lxc"
+arch="all"
+license="LGPL-2.1"
+depends="lua5.3"
+makedepends="automake autoconf libtool lua5.3-dev lxc-dev"
+source="https://github.com/lxc/$_pkgname/archive/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$_pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ ./autogen.sh
+}
+build() {
+ cd "$builddir"
+ export LUA_VERSION=5.3
+ ./configure \
+ --prefix=/usr \
+ --localstatedir=/var \
+ --enable-static=no \
+ --with-lua-pc=lua5.3
+ make
+}
+# LUA_LIBS linker flags for LUA, overriding pkg-config
+# LUA_VERSION value of V for $LUAPKGCONFIG, overriding pkg-config
+check() {
+ cd "$builddir"
+ make check
+}
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" LUA_VERSION=5.3 install
+}
+
+sha512sums="6d0da96fb7437ac14f3010c6bbc750646352c6e60020be4b65db28b73664c2269085379f1e35db71c7b35a19933354194dd6ac656dafac24cb8f433b1ff5fabf lua-lxc-3.0.0.tar.gz"