aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-02-15 14:16:29 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-02-15 14:17:43 +0000
commiteba076522d9b91a86b07fae77f40c95d30ccaae4 (patch)
treeba83ebb073fade851dc7f828baa01efaf549392a /testing
parentc58afb3ad7d833c3592deee52f6546d87923b99b (diff)
downloadaports-eba076522d9b91a86b07fae77f40c95d30ccaae4.tar.bz2
aports-eba076522d9b91a86b07fae77f40c95d30ccaae4.tar.xz
testing/py-simpleparse: new aport
Python library providing simple and fast parser generator
Diffstat (limited to 'testing')
-rw-r--r--testing/py-simpleparse/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/py-simpleparse/APKBUILD b/testing/py-simpleparse/APKBUILD
new file mode 100644
index 0000000000..fc0d566383
--- /dev/null
+++ b/testing/py-simpleparse/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py-simpleparse
+_realname=SimpleParse
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Python library providing simple and fast parser generator"
+url="http://simpleparse.sourceforge.net/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=
+makedepends="$depends_dev"
+install=
+subpackages=
+source="http://downloads.sourceforge.net/project/simpleparse/simpleparse/$pkgver/$_realname-$pkgver.zip"
+
+
+_builddir="$srcdir"/$_realname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir"
+}
+
+md5sums="51d9f2d172032eb4065d2857706219e1 SimpleParse-2.0.0.zip"