aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-29 00:42:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-29 00:42:50 +0200
commit0d42953156ad36105b7f484bd96b25fe2be8dd0e (patch)
tree81a9c08265b15689da2a774b10c5ae1ec358b8af /testing
parentd3fb126a8080da98fc2e820f7f09fd26da165a30 (diff)
downloadaports-0d42953156ad36105b7f484bd96b25fe2be8dd0e.tar.bz2
aports-0d42953156ad36105b7f484bd96b25fe2be8dd0e.tar.xz
community/ruby-nokogiri: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/ruby-nokogiri/APKBUILD81
1 files changed, 0 insertions, 81 deletions
diff --git a/testing/ruby-nokogiri/APKBUILD b/testing/ruby-nokogiri/APKBUILD
deleted file mode 100644
index 54ff1bb8a2..0000000000
--- a/testing/ruby-nokogiri/APKBUILD
+++ /dev/null
@@ -1,81 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=ruby-nokogiri
-_gemname=${pkgname#ruby-}
-pkgver=1.7.1
-pkgrel=0
-pkgdesc="An HTML, XML, SAX, and Reader parser"
-url="http://nokogiri.org/"
-arch="all"
-license="MIT"
-depends="ruby ruby-mini_portile2"
-makedepends="ruby-dev libxml2-dev libxslt-dev"
-checkdepends="ruby-minitest"
-source="https://rubygems.org/downloads/$_gemname-$pkgver.gem"
-builddir="$srcdir/$_gemname-$pkgver"
-options="!check" # FIXME: some tests fails due to encoding issues
-
-unpack() {
- default_unpack
-
- cd "$srcdir"
- gem unpack $_gemname-$pkgver.gem
-}
-
-prepare() {
- default_prepare
-
- cd "$builddir"
-
- # Generate gemspec (there's no gemspec in the source).
- gem specification -l --ruby "$srcdir"/$_gemname-$pkgver.gem \
- > "$builddir"/$_gemname.gemspec
-
- # Remove bundled external libraries etc.
- sed -i \
- -e 's|, "ports/archives/[^"][^"]*"||g' \
- -e 's|, "ports/patches/[^"][^"]*"||g' \
- -e '\@mini_portile@d' \
- $_gemname.gemspec
-}
-
-build() {
- cd "$builddir"
-
- gem build $_gemname.gemspec
- gem install \
- --local \
- --install-dir dist \
- --ignore-dependencies \
- --no-document \
- --verbose \
- $_gemname-$pkgver.gem -- \
- --use-system-libraries
-}
-
-check() {
- cd "$builddir"/dist/gems/$_gemname-$pkgver
-
- # Note: This is copied from Fedora package.
- export LANG=ja_JP.UTF-8
- ruby -I.:lib:test:ext \
- -e 'require "test/helper"' \
- -e 'Dir.glob("test/**/test_*.rb") {|f| require f }'
-}
-
-package() {
- local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
-
- cd "$builddir"/dist
-
- mkdir -p "$gemdir"
- cp -r bin extensions gems specifications "$gemdir"/
-
- cd "$gemdir"/gems/$_gemname-$pkgver
-
- # Remove unnecessary files and rubbish...
- rm -r ext/ patches/ suppressions/ tasks/ test/ \
- build_all test_all Rakefile .[a-z]* *.md *.rdoc *.txt *.yml || true
-}
-
-sha512sums="86ae6d09d6daf0be2d6b46c4a5c8ebe6e9c00e7a4dfe86a2d1c7972726696a87d89e95fa390697a9cb3bae5f7d419c9a4f6d70b1a02c47ab0119bb14bc67efb3 nokogiri-1.7.1.gem"