aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-22 16:57:02 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:29:03 +0000
commit167cede9275e397d4f4886c17eb42f0ff999823b (patch)
tree72a2c349ae5a5bc69e599b95b4ccea44211b3f6a /testing
parent8103724a4bdc6a1686a86d8374ef03f95d44630f (diff)
downloadaports-167cede9275e397d4f4886c17eb42f0ff999823b.tar.bz2
aports-167cede9275e397d4f4886c17eb42f0ff999823b.tar.xz
testing/fuse3: upgrade to 3.2.1; add check
Diffstat (limited to 'testing')
-rw-r--r--testing/fuse3/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/testing/fuse3/APKBUILD b/testing/fuse3/APKBUILD
index ef842de8ba..6d021fa743 100644
--- a/testing/fuse3/APKBUILD
+++ b/testing/fuse3/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fuse3
_pkgname=fuse
-pkgver=3.2.0
+pkgver=3.2.1
pkgrel=1
pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
url="https://github.com/libfuse/libfuse/"
arch="all"
license="GPL-2.0"
depends="!fuse"
-makedepends="gettext-dev linux-headers meson eudev-dev"
+makedepends="gettext-dev linux-headers meson eudev-dev python3 py3-six py3-pluggy py3-attrs py3-py"
+checkdepends="py3-pytest"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/libfuse/libfuse/releases/download/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.xz
fix-realpath.patch
@@ -29,6 +30,11 @@ build() {
ninja -C output
}
+check() {
+ cd "$builddir"
+ python3 -m pytest test/
+}
+
package() {
cd "$builddir"
DESTDIR="$pkgdir" ninja -C output install
@@ -51,6 +57,6 @@ _EOF_
}
-sha512sums="43f6bb6e40b797c82e156608f5b8d6fea7b71d63b17d3eb525c85c6437642991a352a76be6193b3f652a29b41d346949e946e6d3d5534ef4dbf4aa2caad21342 fuse-3.2.0.tar.xz
+sha512sums="edf08711fa02c40b9d3507c99e0b1bfd7208edc1494888c4e2bad92b621eb5c43c4cb31474d2d3bb1edaaf9cd876f3407cdb00a1bdcf61a0b74c876d3707518e fuse-3.2.1.tar.xz
1a9e1d1e8a7b0778ffde328e4322c73b5d57ec98d52767c846d755cce861ab27989823a75b6c5f994432ddb77fa351dfa4a8f948c9467c5f7d5f471e4608358b fix-realpath.patch
7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd"