aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-08 12:30:40 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-08 09:19:41 -0300
commit0c097652995acff0e1a9892a176f73cb84dd4a74 (patch)
tree9182200600714be48c7612b731ac53695a5873b4 /testing
parentc5a8dac6ab18d7fe88ab46d574e97e10010f3709 (diff)
downloadaports-0c097652995acff0e1a9892a176f73cb84dd4a74.tar.bz2
aports-0c097652995acff0e1a9892a176f73cb84dd4a74.tar.xz
testing/rustup: upgrade to 1.18.3
Diffstat (limited to 'testing')
-rw-r--r--testing/rustup/APKBUILD41
-rw-r--r--testing/rustup/dont-copy-rustup-bin.patch14
2 files changed, 36 insertions, 19 deletions
diff --git a/testing/rustup/APKBUILD b/testing/rustup/APKBUILD
index 231269082b..ac022b2521 100644
--- a/testing/rustup/APKBUILD
+++ b/testing/rustup/APKBUILD
@@ -1,23 +1,26 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=rustup
-pkgver=1.16.0
+pkgver=1.18.3
pkgrel=0
pkgdesc="The Rust toolchain installer"
url="rustup.rs"
arch="x86_64" # limited by cargo
license="Apache-2.0"
makedepends="cargo perl openssl-dev zlib-dev curl-dev"
-options="!check" # Doesn't recognise x86_64-unknown-linux-musl yet, so it tries
- # to test with nonexistent x86_64-unknown-linux
+options="!check" # Doesn't recognise x86_64-unknown-linux-musl yet
subpackages="
$pkgname-bash-completion:bashcomp:noarch
$pkgname-fish-completion:fishcomp:noarch
$pkgname-zsh-completion:zshcomp:noarch"
source="
- $pkgname-$pkgver.tar.gz::https://github.com/rust-lang/rustup.rs/archive/${pkgver}.tar.gz"
+ $pkgname-$pkgver.tar.gz::https://github.com/rust-lang/rustup.rs/archive/${pkgver}.tar.gz
+ dont-copy-rustup-bin.patch"
builddir="$srcdir/rustup.rs-${pkgver}"
+# It doesn't like our custom triplet
+export RUSTUP_OVERRIDE_BUILD_TRIPLE="x86_64-unknown-linux-musl"
+
build() {
cargo build --release --features no-self-update --bin rustup-init
}
@@ -37,28 +40,28 @@ package() {
}
bashcomp() {
- pkgdesc="$pkgdesc - bash completion"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ pkgdesc="$pkgdesc - bash completion"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- install -Dm644 "$builddir"/rustup.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+ install -Dm644 "$builddir"/rustup.bash \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
}
fishcomp() {
- pkgdesc="$pkgdesc - fish shell completion"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel fish"
+ pkgdesc="$pkgdesc - fish shell completion"
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
- install -Dm644 "$builddir"/rustup.fish \
- "$subpkgdir"/usr/share/fish/completions/$pkgname.fish
+ install -Dm644 "$builddir"/rustup.fish \
+ "$subpkgdir"/usr/share/fish/completions/$pkgname.fish
}
zshcomp() {
- pkgdesc="$pkgdesc -zsh completion"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ pkgdesc="$pkgdesc -zsh completion"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
- install -Dm644 "$builddir"/rustup.zsh \
- "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
+ install -Dm644 "$builddir"/rustup.zsh \
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-sha512sums="413aada75d90b7c8946edd62e05c526f65e7b34899ac4afe711ba79ab2a1e3e6366c84a3b5996df7de804ef6db98d571ad4aa4bc3f46faed30ebf6eb2ac7e58c rustup-1.16.0.tar.gz"
+sha512sums="6148bbeca954f6d4a7b319733ef4a25916b96bcbd1568c92687f5596219033f2b2cd354b71b8348411cc9d34b48e9a401b3970a954c29516fb978f15cedbb9d4 rustup-1.18.3.tar.gz
+ca28b41a638fe5b1e8b0dcb549bdbed04bada7f41759d14a374dbc6f0823df57c08b65aa4fbce05ced3deafcb96ee3ae38b187ca29e1a9183ee5e91f8577400c dont-copy-rustup-bin.patch"
diff --git a/testing/rustup/dont-copy-rustup-bin.patch b/testing/rustup/dont-copy-rustup-bin.patch
new file mode 100644
index 0000000000..bcc6f5ce36
--- /dev/null
+++ b/testing/rustup/dont-copy-rustup-bin.patch
@@ -0,0 +1,14 @@
+Upstream: No, not upstreamable like this
+Reason: We want the rustup binary in $CARGO_HOME/bin to be of the
+same version as the one we distribute in this rustup package.
+--- a/src/cli/self_update.rs.1 2018-12-13 21:56:55.211778812 +0100
++++ b/src/cli/self_update.rs 2018-12-13 21:56:42.763779768 +0100
+@@ -619,8 +619,7 @@
+ if rustup_path.exists() {
+ utils::remove_file("rustup-bin", &rustup_path)?;
+ }
+- utils::copy_file(&this_exe_path, &rustup_path)?;
+- utils::make_executable(&rustup_path)?;
++ utils::symlink_file(&this_exe_path, &rustup_path)?;
+ install_proxies()
+ }