aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-26 13:00:15 +0200
committerprspkt <prspkt@protonmail.com>2019-03-26 13:07:08 +0200
commit203742bc6e6d1b80af0fbfec851b434c9c18b88a (patch)
tree5d9fd9ed352404047d7fe701de5b061925e5ee10 /testing
parentd910a80a8971c8d04973fc3cd81a8bbcd612dd17 (diff)
downloadaports-203742bc6e6d1b80af0fbfec851b434c9c18b88a.tar.bz2
aports-203742bc6e6d1b80af0fbfec851b434c9c18b88a.tar.xz
testing/py3-columnize: fix url, modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-columnize/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/testing/py3-columnize/APKBUILD b/testing/py3-columnize/APKBUILD
index d841b02826..5e2271d18d 100644
--- a/testing/py3-columnize/APKBUILD
+++ b/testing/py3-columnize/APKBUILD
@@ -5,29 +5,24 @@ _pkgname=columnize
pkgver=0.3.6
pkgrel=1
pkgdesc="Python module to align in columns a simple list"
-url="https://code.google.com/p/pycolumnize/"
+url="https://github.com/rocky/pycolumnize"
arch="noarch"
license="MIT"
provides="py-columnize" # for backwards compatibility
replaces="py-columnize=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-depends_dev=""
makedepends="python3-dev py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="820361100672d798ec241a63de64131c columnize-0.3.6.tar.gz"
-sha256sums="2a6004a1076dddf711c222fae4c165d17f86c14c00de37b738fa7c1d2b539e9d columnize-0.3.6.tar.gz"
sha512sums="76edef11eb7c4196516fca282a46cae0d56f8ce1229cbedc066518216dbaada30f7a37ca9b510dedabe3954faf55daea7bd5356bc9e6301cdc0fe771f1b401d7 columnize-0.3.6.tar.gz"