aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-03-26 21:18:28 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-03-27 15:51:13 +0200
commit36cda70436194dc1c977eee95fdd23efa09ec44a (patch)
tree3d1e1755c4aca16b711be15bd2ceae0a2747488a /testing
parentda453c49b9449b98658701cb593721bfd3b78bec (diff)
downloadaports-36cda70436194dc1c977eee95fdd23efa09ec44a.tar.bz2
aports-36cda70436194dc1c977eee95fdd23efa09ec44a.tar.xz
testingphp7-pecl-protobuf: moved from testing/php7-protobuf and added check()
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-pecl-protobuf/APKBUILD (renamed from testing/php7-protobuf/APKBUILD)12
1 files changed, 9 insertions, 3 deletions
diff --git a/testing/php7-protobuf/APKBUILD b/testing/php7-pecl-protobuf/APKBUILD
index 5be9488731..0ded2c0574 100644
--- a/testing/php7-protobuf/APKBUILD
+++ b/testing/php7-pecl-protobuf/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: TBK <alpine@jjtc.eu>
# Maintainer: TBK <alpine@jjtc.eu>
-pkgname=php7-protobuf
+pkgname=php7-pecl-protobuf
_pkgreal=protobuf
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="PHP7 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data."
url="https://pecl.php.net/package/protobuf"
arch="all"
license="BSD-3-Clause"
-options="!check" # Test suite is not part of pecl release.
depends="php7-common"
makedepends="php7-dev autoconf libtool"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-protobuf=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-protobuf" # for backward compatibility
build() {
cd "$builddir"
@@ -21,6 +22,11 @@ build() {
make
}
+check() {
+ # Test suite is not a part of pecl release.
+ php7 -d extension="$builddir"/modules/$_pkgreal.so --ri $_pkgreal
+}
+
package() {
cd "$builddir"
make INSTALL_ROOT="$pkgdir" install