aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2020-03-09 22:09:08 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-09 19:27:30 -0300
commit3841e1c3e815c37835fab0b4e3c2f5487faae3f3 (patch)
tree23c79268bf1d9eba9e220855a14210a5e164d435 /testing
parent62f93a5bf25c6b15ee1565a6e41555a53159158f (diff)
downloadaports-3841e1c3e815c37835fab0b4e3c2f5487faae3f3.tar.bz2
aports-3841e1c3e815c37835fab0b4e3c2f5487faae3f3.tar.xz
testing/py3-shapely: upgrade to 1.7.0
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-shapely/APKBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/testing/py3-shapely/APKBUILD b/testing/py3-shapely/APKBUILD
index 8ec8c879c3..b11243d79f 100644
--- a/testing/py3-shapely/APKBUILD
+++ b/testing/py3-shapely/APKBUILD
@@ -1,14 +1,11 @@
# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
-_pkgname=shapely
-pkgname=py3-$_pkgname
-pkgver=1.6.4_p2
-_pkgverbase=${pkgver%_p*}
-_pkgversuffix=.post${pkgver#*_p}
-pkgrel=2
+pkgname=py3-shapely
+pkgver=1.7.0
+pkgrel=0
pkgdesc="Manipulation and analysis of geometric objects in the Cartesian plane"
url="https://pypi.python.org/pypi/Shapely"
-arch="all s390x"
+arch="all !s390x" # geos availability
license="BSD-3-Clause"
depends="
py3-numpy
@@ -26,15 +23,17 @@ checkdepends="
py3-pytest
"
source="
- https://pypi.io/packages/source/S/Shapely/Shapely-$_pkgverbase$_pkgversuffix.tar.gz
+ https://pypi.io/packages/source/S/Shapely/Shapely-$pkgver.tar.gz
10-packaging.patch
- skip-test-that-fails-with-python-3.8.patch
"
-builddir="$srcdir/Shapely-$_pkgverbase$_pkgversuffix"
+builddir="$srcdir/Shapely-$pkgver"
build() {
rm -r _vendor # This is provided by py3-packaging
+ cython shapely/speedups/_speedups.pyx
+ cython shapely/vectorized/_vectorized.pyx
+
python3 setup.py build
}
@@ -54,6 +53,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
}
-sha512sums="027c816ef2104f654569ca658b52b87c60e5ba6a45927fcc51c23dd1922f3f9f7fdcea3601160b0a999e39611617142833ccac790777093be8b96a0d9083f78f Shapely-1.6.4.post2.tar.gz
-7cebaf4e059d71e1cd374539eb056491afbf736e05bf369a3c6533306885940d108340ada56ec7662e30aac04d2bd3ac4019ccf2fc447151d2274009d93d00fe 10-packaging.patch
-5b345c1bfdada6c4729195ba8bcf468e8253281293e314cfa46295face63e7d5baeeedadae20026749530c1a92575fa222637b5c77b5751e6c7ae751ee88f743 skip-test-that-fails-with-python-3.8.patch"
+sha512sums="ff7a14f20c05e3949c1e689175b80ec1f8248a0f45370a6313dbf4319ec018a8fafcfd171efbaa81bd8ceaab9c54488feca61bb03067e22a275da2b8663dc8bc Shapely-1.7.0.tar.gz
+7cebaf4e059d71e1cd374539eb056491afbf736e05bf369a3c6533306885940d108340ada56ec7662e30aac04d2bd3ac4019ccf2fc447151d2274009d93d00fe 10-packaging.patch"