aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 00:22:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-07 07:31:04 -0300
commit52273ae21b1a1746ecda51bb71f83fc34ae06529 (patch)
tree83ab193a792297fc7223f9b920c46a6a7dca9be7 /testing
parent516fa750094a80cc99bd188e1db44395a22ccb5d (diff)
downloadaports-52273ae21b1a1746ecda51bb71f83fc34ae06529.tar.bz2
aports-52273ae21b1a1746ecda51bb71f83fc34ae06529.tar.xz
testing/py-pyechonest: modernize, fix license.
Diffstat (limited to 'testing')
-rw-r--r--testing/py-pyechonest/APKBUILD25
1 files changed, 5 insertions, 20 deletions
diff --git a/testing/py-pyechonest/APKBUILD b/testing/py-pyechonest/APKBUILD
index 846e729297..cfebcd7cec 100644
--- a/testing/py-pyechonest/APKBUILD
+++ b/testing/py-pyechonest/APKBUILD
@@ -3,37 +3,22 @@
pkgname=py-pyechonest
_pkgname=pyechonest
pkgver=9.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="A Python interface to The Echo Nest APIs"
url="https://pypi.python.org/pypi/pyechonest"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="python2 py-simplejson py-setuptools"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
md5sums="c633dce658412e3ec553efd25d7d2686 pyechonest-9.0.0.tar.gz"