aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-04-03 16:27:10 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-05 11:55:30 +0000
commit56095828ba0c36b2c66daf34d3c76ac8517d47d3 (patch)
tree118dc3d40b5137a0f659421b6a378cb2be73f40a /testing
parentf359f656d8df48f0b50f264a5450379cc923c8eb (diff)
downloadaports-56095828ba0c36b2c66daf34d3c76ac8517d47d3.tar.bz2
aports-56095828ba0c36b2c66daf34d3c76ac8517d47d3.tar.xz
main/py-hypothesis: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/py-hypothesis/APKBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/testing/py-hypothesis/APKBUILD b/testing/py-hypothesis/APKBUILD
deleted file mode 100644
index 783aaab202..0000000000
--- a/testing/py-hypothesis/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=py-hypothesis
-pkgver=4.14.3
-pkgrel=0
-pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
-url="http://hypothesis.works/"
-arch="noarch"
-license="MPL-2.0"
-depends="py-coverage"
-_py2_deps="py2-coverage"
-_py3_deps="py3-coverage"
-makedepends="
- $_py2_deps $_py3_deps python2-dev python3-dev py2-setuptools py3-setuptools
- py-enum34
-"
-subpackages="py2-hypothesis:_py py3-hypothesis:_py"
-source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz"
-builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python2 setup.py check
- python3 setup.py check
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-_py() {
- local py=${subpkgname%%-*}
- local python="python${py#py}"
- depends="$python"
- case $py in
- py2) depends="$depends py-enum34";;
- esac
- pkgdesc="$pkgdesc ($python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/${python}* "$subpkgdir"/usr/lib/
-}
-
-sha512sums="56f0a796741b1a46bfe91e578dc76067b612d0041dd8b93043521c8e53827a5bcdd815f94e91d22d4ae9d13125bfb9012cb1c4660635e7cc93472141be504efb py-hypothesis-4.14.3.tar.gz"