aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-25 10:50:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-25 13:26:44 +0000
commit67ef956a27f195cf4c5e3b6b62712b98dae3624b (patch)
tree07e11513af470faedb4e37e9a065f35c750152a3 /testing
parent5a139d90fddef86a140f5dc52f95dd0548de4525 (diff)
downloadaports-67ef956a27f195cf4c5e3b6b62712b98dae3624b.tar.bz2
aports-67ef956a27f195cf4c5e3b6b62712b98dae3624b.tar.xz
testing/libtls-standalone: install libtls.so symlink
Diffstat (limited to 'testing')
-rw-r--r--testing/libtls-standalone/APKBUILD4
-rw-r--r--testing/libtls-standalone/Makefile1
2 files changed, 3 insertions, 2 deletions
diff --git a/testing/libtls-standalone/APKBUILD b/testing/libtls-standalone/APKBUILD
index 7ebaa47976..a05d7dbf34 100644
--- a/testing/libtls-standalone/APKBUILD
+++ b/testing/libtls-standalone/APKBUILD
@@ -2,7 +2,7 @@
pkgname=libtls-standalone
pkgver=2.7.4
_namever=${pkgname}${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="libtls extricated from libressl sources"
url="http://www.libressl.org/"
arch="all"
@@ -56,7 +56,7 @@ package() {
}
sha512sums="1cd82a1bff4f655251b5feb0c850f4164e0fd548e4b404407370f74dcc75c205f42efc7787a157eecac84cbbe46af48cb63f46b3fef75f4a0a9ea19a5863a691 libressl-2.7.4.tar.gz
-28e08af50fbcb286d413a2df2b063ee90675561c1501d24d33e17c142b85f404a27c4954644d65e367c925981e514dcaad6d311c768162cd02f3eea0db15d14d Makefile
+c898c5b9c426a09291dcf7df4336476d7296cea62b080ef245670adea77765877d989f492d66db998fefb36c1cca8e26d10801227654f5565ee642cf47ffaa98 Makefile
be8216d08a6992ca65a8e3f1e010645833899465090179f269a62de5fcfe2711d463fe1aa57e408492648878fa2ee53377c4509ef48a2aafe3f267cce73e9209 tls_compat.c
0b8fca899e1f7b51979d69458be23c77c1b7f265ed60de76cf5cfb9eb5742111cf50813bd35384831301523a6a0562a20acf1aec22dc0d9ad653271d45ede915 tls_compat.h
71d36fe25c95a0a45497e3f699b01dddcaae9053dd1b1e2419df94272c47024cf6516c51c902129201061601b04a72551904b15a332a4cf53358983b5db73618 test_program.c
diff --git a/testing/libtls-standalone/Makefile b/testing/libtls-standalone/Makefile
index 453804d41e..7b6806ecb4 100644
--- a/testing/libtls-standalone/Makefile
+++ b/testing/libtls-standalone/Makefile
@@ -63,6 +63,7 @@ clean:
install:
install -D -m755 libtls.so.${LIBTLS_FULLVERSION} ${DESTDIR}${PREFIX}/lib/libtls.so.${LIBTLS_FULLVERSION}
ln -sf libtls.so.${LIBTLS_FULLVERSION} ${DESTDIR}${PREFIX}/lib/libtls.so.${LIBTLS_SOVERSION}
+ ln -sf libtls.so.${LIBTLS_FULLVERSION} ${DESTDIR}${PREFIX}/lib/libtls.so
install -D -m644 ${LIBRESSL_SRCDIR}/include/tls.h ${DESTDIR}${PREFIX}/include/tls.h