aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-07 21:21:40 +0300
committerprspkt <prspkt@protonmail.com>2019-06-09 22:43:20 +0300
commit694726720a6a826735c796dea96cc6bbd5fa7080 (patch)
tree9fbad25389f0cbf85cb2ce876871b0b31482c341 /testing
parent92f385d53ccaa0866feea895342f87fea070af9a (diff)
downloadaports-694726720a6a826735c796dea96cc6bbd5fa7080.tar.bz2
aports-694726720a6a826735c796dea96cc6bbd5fa7080.tar.xz
testing/py-sphinxcontrib-phpdomain: upgrade to python3
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-sphinxcontrib-phpdomain/APKBUILD (renamed from testing/py-sphinxcontrib-phpdomain/APKBUILD)13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/py-sphinxcontrib-phpdomain/APKBUILD b/testing/py3-sphinxcontrib-phpdomain/APKBUILD
index cf7b276eb3..ffbbaa32ab 100644
--- a/testing/py-sphinxcontrib-phpdomain/APKBUILD
+++ b/testing/py3-sphinxcontrib-phpdomain/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinxcontrib-phpdomain
+pkgname=py3-sphinxcontrib-phpdomain
_pkgname=sphinxcontrib-phpdomain
pkgver=0.1.4
pkgrel=0
@@ -8,9 +8,9 @@ pkgdesc="Sphinx phpdomain extension"
url="https://pypi.python.org/pypi/sphinxcontrib-phpdomain"
arch="noarch"
license="BSD"
-depends="python2 py-sphinx"
+depends="py3-sphinx"
depends_dev=""
-makedepends="python2-dev py-setuptools"
+makedepends="py3-setuptools"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -26,14 +26,17 @@ prepare() {
done
}
+replaces=py-sphinxcontrib-phpdomain" # for backwards compatibility
+provides=py-sphinxcontrib-phpdomain=$pkgver-r$pkgrel" # for backwards compatibility
+
build() {
cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="03ce0f0569db0217f7471c2f7e952841 sphinxcontrib-phpdomain-0.1.4.tar.gz"