aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-12-31 16:53:04 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-01-01 21:23:49 +0100
commit93664b3a029fe8572430b062228da01510d0a67a (patch)
tree25ed64b21674b366aa683cbe85b0e8093d23aac5 /testing
parent95ea9b1c304afceb0bfb1d63e7e8657e1c797e2c (diff)
downloadaports-93664b3a029fe8572430b062228da01510d0a67a.tar.bz2
aports-93664b3a029fe8572430b062228da01510d0a67a.tar.xz
testing/gnurl: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/gnurl/APKBUILD80
1 files changed, 80 insertions, 0 deletions
diff --git a/testing/gnurl/APKBUILD b/testing/gnurl/APKBUILD
new file mode 100644
index 0000000000..f206d98809
--- /dev/null
+++ b/testing/gnurl/APKBUILD
@@ -0,0 +1,80 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer:
+pkgname=gnurl
+pkgver=7.65.3
+pkgrel=0
+pkgdesc="A micro fork of libcurl"
+url="https://gnunet.org/en/gnurl.html"
+arch="all"
+license="MIT"
+depends="ca-certificates"
+depends_dev="gnutls-dev libidn2-dev zlib-dev"
+checkdepends="python3"
+makedepends="$depends_dev perl"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+source="https://mirror.kumi.systems/gnu/gnunet/gnurl-$pkgver.tar.gz"
+builddir="$srcdir/gnurl-$pkgver"
+
+build() {
+ # Note: The second group of options is based on
+ # http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/www/gnurl/Makefile?rev=1.9&content-type=text/x-cvsweb-markup.
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --enable-ipv6 \
+ --enable-static \
+ --enable-unix-sockets \
+ --with-ca-path=/etc/ssl/certs \
+ --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
+ --with-pic \
+ \
+ --without-libssh2 \
+ --without-libmetalink \
+ --without-winidn \
+ --without-librtmp \
+ --without-nghttp2 \
+ --without-nss \
+ --without-cyassl \
+ --without-ssl \
+ --without-winssl \
+ --without-darwinssl \
+ --disable-sspi \
+ --disable-ldap \
+ --without-libpsl \
+ --disable-rtsp \
+ --disable-dict \
+ --disable-telnet \
+ --disable-tftp \
+ --disable-pop3 \
+ --disable-imap \
+ --disable-smtp \
+ --disable-gopher \
+ --disable-file \
+ --disable-ftp \
+ --disable-smb \
+ --disable-ntlm-wb \
+ --with-gnutls \
+ --with-libidn2 \
+ --with-libz \
+ --without-ca-fallback \
+ --without-gssapi \
+ --disable-valgrind \
+ --without-ngtcp2 \
+ --without-nghttp2 \
+ --without-nghttp3 \
+ --without-quiche
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="51aa71352dfe2e65dbcf542cb616af1eaa7e80fbc4ddb455a338e74eea245724ac1fa7ff226c418101e8ba298a8f85c2be9e7d9190a57c66e2e8c65d0c5186f8 gnurl-7.65.3.tar.gz"