aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2020-01-14 10:35:24 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-10 19:39:30 -0300
commit99c547f1f18bd724b2d6060d41215929d904bd76 (patch)
tree2ac0d385d481530c70bc2d08d502901652baf259 /testing
parent04050ff0a041735d21485fdcf00381d982a11752 (diff)
downloadaports-99c547f1f18bd724b2d6060d41215929d904bd76.tar.bz2
aports-99c547f1f18bd724b2d6060d41215929d904bd76.tar.xz
testing/openv2g: Enable V2G build on all archs
Previously, prepare failed due to wrong line-endings when building on the main runner, but not on the gitlab runner. Instead, make sure all the files we want to patch, are properly ended by dos2unix-ing them. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'testing')
-rw-r--r--testing/openv2g/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/testing/openv2g/APKBUILD b/testing/openv2g/APKBUILD
index 9587087957..0a11bf1c62 100644
--- a/testing/openv2g/APKBUILD
+++ b/testing/openv2g/APKBUILD
@@ -1,22 +1,25 @@
# Contributor: Olliver Schinagl <oliver@schinagl.nl>
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
-pkgname="openv2g"
-pkgver="0.9.4"
+pkgname=openv2g
+pkgver=0.9.4
pkgrel=0
pkgdesc="Implements ISO IEC 15118 and also the DIN 70121 vehicle to grid (V2G) communication interface"
url="https://openv2g.org/"
-arch=""
+arch="all"
license="LGPL-3.0-or-later"
options="!check" # No tests available
-subpackages="lib${pkgname}:libs ${pkgname}-dev"
+subpackages="lib$pkgname:libs $pkgname-dev"
source="
makefiles.patch
- ${pkgname}-${pkgver}.zip::https://downloads.sourceforge.net/sourceforge/openv2g/OpenV2G_${pkgver}.zip
+ $pkgname-$pkgver.zip::https://downloads.sourceforge.net/sourceforge/openv2g/OpenV2G_$pkgver.zip
"
unpack() {
- mkdir -p "${builddir}"
- unzip "${srcdir}/${pkgname}-${pkgver}.zip" -d "${builddir}"
+ mkdir -p "$builddir"
+ unzip "$srcdir/$pkgname-$pkgver.zip" -d "$builddir"
+ find "$builddir" \
+ \( -iname 'makefile' -o -iname '*.mk' \) \
+ -exec dos2unix '{}' \;
}
build() {
@@ -25,10 +28,10 @@ build() {
}
package() {
- depends="lib${pkgname}"
+ depends="lib$pkgname"
cd Release
- make DESTDIR="${pkgdir}/usr" install
+ make DESTDIR="$pkgdir/usr" install
}
-sha512sums="8ecb2b31ad9cd8cdb62e5bb32c4e535e2c6717d4d1809f7e42588a0b3071902c54de9be75e0b908ac5ab283aea9375080f6b4a5c4f002e4c27736266a68a2e2f makefiles.patch
+sha512sums="5c4e8df3033a9ebed412a004efdb812528e3d7c7e8d126dc1a1139c106391eeba58a7b13f88a21d4addd176b6f65dee3d1e2243cb46177628c5dd2b6e3f59f33 makefiles.patch
0fe088bc3ae0f0dc6af8c9c3a989301e5e155a9406b80cb9025ceb5b548dc94202dde37993711c589fac6eddf626897c7ef003b73e01cb1c5b20b7b73365b930 openv2g-0.9.4.zip"