aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-05-13 09:09:42 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-13 10:29:59 +0000
commitaeff71c24acc8f389289b95b3c6f40c70a5128c2 (patch)
treebee0b61bc35f46fce825bfc0ed90a2a21e4cbb69 /testing
parent46a53f455e005ba70024f9b1b889f0a476af52d1 (diff)
downloadaports-aeff71c24acc8f389289b95b3c6f40c70a5128c2.tar.bz2
aports-aeff71c24acc8f389289b95b3c6f40c70a5128c2.tar.xz
testing/perl-text-charwidth: new aport
Closes GH-7862
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-text-charwidth/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/perl-text-charwidth/APKBUILD b/testing/perl-text-charwidth/APKBUILD
new file mode 100644
index 0000000000..a2c380275b
--- /dev/null
+++ b/testing/perl-text-charwidth/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=perl-text-charwidth
+pkgver=0.04
+pkgrel=0
+pkgdesc="Text:CharWidth perl module"
+url="https://metacpan.org/pod/Text::CharWidth"
+arch="all"
+license="Artistic-1.0-Perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/K/KU/KUBOTA/Text-CharWidth-$pkgver.tar.gz"
+builddir="$srcdir/Text-CharWidth-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="8ec7898fcd4a3bb6e9e36fbd50c28e023298f830fce33dafd1445de97732b337d3a6f9a075059a56592d0f118ba83c45e61fa4fd4a6d3bfbb2cd25215a061e1c Text-CharWidth-0.04.tar.gz"