aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-08-03 02:27:43 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-08-06 11:26:53 +0300
commitaf218da5cf2de5c124b41281b91f50c96b6e3159 (patch)
tree651a1317bf6c12520ffb4d7aaf3c1f1261eff64e /testing
parent062fe1d193c11b526f2e01104aff65f74483fe20 (diff)
downloadaports-af218da5cf2de5c124b41281b91f50c96b6e3159.tar.bz2
aports-af218da5cf2de5c124b41281b91f50c96b6e3159.tar.xz
testing/php7-xhprof: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-xhprof/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/php7-xhprof/APKBUILD b/testing/php7-xhprof/APKBUILD
new file mode 100644
index 0000000000..0ecbbe0f71
--- /dev/null
+++ b/testing/php7-xhprof/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Andy Postnikov <apostnikov@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+
+pkgname=php7-xhprof
+_pkgreal=xhprof
+pkgver=2.0.2
+pkgrel=0
+pkgdesc="A Hierarchical Profiler for PHP"
+url="https://github.com/longxinH/xhprof"
+arch="all"
+license="Apache-2.0"
+depends="php7 php7-ctype"
+makedepends="php7-dev autoconf"
+subpackages="$pkgname-assets::noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/longxinH/xhprof/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"/extension
+ phpize7
+ ./configure --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"/extension
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 -f Makefile.local test_with_exit_status
+}
+
+package() {
+ cd "$builddir"/extension
+ make INSTALL_ROOT="$pkgdir"/ install
+ local confdir="$pkgdir/etc/php7/conf.d"
+ install -d "$confdir"
+ cat > "$confdir"/$_pkgreal.ini <<-EOF
+ extension=$_pkgreal.so
+ xhprof.output_dir=/tmp
+ EOF
+ local installdir="$pkgdir"/usr/share/php7/xhprof
+ install -d "$installdir"
+ cp -R "$builddir"/xhprof_lib "$installdir"
+}
+
+assets() {
+ pkgdesc="A Hierarchical Profiler for PHP (UI assets)"
+ depends="$pkgname graphviz ghostscript-fonts"
+
+ local installdir="$subpkgdir"/usr/share/php7/xhprof
+ install -d "$installdir"
+ cp -R "$builddir"/xhprof_html "$installdir"
+ cp -R "$builddir"/examples "$installdir"
+}
+
+sha512sums="6a3ea7994e7d23852d5265371bf59bfa41a3aab2e107b0293b8945adbbda78302ba827f95a54e0780582f06d9487d6e1894ecc2daada20c2ae87fa952e3ffd08 php7-xhprof-2.0.2.tar.gz"