aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-30 01:04:10 +0200
committerprspkt <prspkt@protonmail.com>2019-03-30 01:36:27 +0200
commitb4b1ce6f670c17f23010152e20ddb10dfdfd7278 (patch)
tree65164ba916b4a9ac49fc0f13cd81a64555f35513 /testing
parentd8b5064c0196aa2f3e0f63fbe2e50a2810756479 (diff)
downloadaports-b4b1ce6f670c17f23010152e20ddb10dfdfd7278.tar.bz2
aports-b4b1ce6f670c17f23010152e20ddb10dfdfd7278.tar.xz
testing/py3-pysendfile: modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pysendfile/APKBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/testing/py3-pysendfile/APKBUILD b/testing/py3-pysendfile/APKBUILD
index c7e22b15c0..6a5f9cc15f 100644
--- a/testing/py3-pysendfile/APKBUILD
+++ b/testing/py3-pysendfile/APKBUILD
@@ -4,40 +4,25 @@ pkgname=py3-pysendfile
_pkgname=pysendfile
pkgver=2.0.1
pkgrel=0
-pkgdesc="A Python interface to sendfile"
-url="https://pypi.python.org/pypi/pysendfile"
+pkgdesc="Python interface to the sendfile(2) system call"
+url="https://pypi.org/project/pysendfile"
arch="all"
license="MIT"
provides="py-sendfile" # for backwards compatibility
replaces="py-sendfile=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-depends_dev=""
makedepends="python3-dev py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="e7b301eddd703ab74a48c59a8fda1f97 pysendfile-2.0.1.tar.gz"
-sha256sums="510a414b270986fba3c79cb76d90a4c910c701bfb43ff983a5d4e92846050e17 pysendfile-2.0.1.tar.gz"
sha512sums="d6ee08eb251fac30c90a9ee829fd992f3620697eef2893ced5a2c6273486c3c5fd35c70962585a8d747d578817391f91c929bfeeba8c4485d52a15748229ca9c pysendfile-2.0.1.tar.gz"