aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-28 14:19:27 -0300
committerTBK <tbk@jjtc.eu>2019-05-28 20:15:30 +0200
commitc8c4b3ddebf9ef8c23d8c182e35f9f732bf29827 (patch)
tree58ee9491e6a968f4fab4bc10d786371de40d7bdd /testing
parenteee164dc5ea6319e913809ceebe41aa741d02374 (diff)
downloadaports-c8c4b3ddebf9ef8c23d8c182e35f9f732bf29827.tar.bz2
aports-c8c4b3ddebf9ef8c23d8c182e35f9f732bf29827.tar.xz
testing/neomutt: modernize, fix license, enable tests
Closes: GH-8212
Diffstat (limited to 'testing')
-rw-r--r--testing/neomutt/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/testing/neomutt/APKBUILD b/testing/neomutt/APKBUILD
index 844578c04a..59423a7593 100644
--- a/testing/neomutt/APKBUILD
+++ b/testing/neomutt/APKBUILD
@@ -2,18 +2,15 @@
# Maintainer: Leo <thinakbit.ukim@gmail.com>
pkgname=neomutt
pkgver=20180716
-pkgrel=0
+pkgrel=1
pkgdesc="Mutt with miscellaneous fixes and feature patches"
url="https://www.neomutt.org/"
arch="all"
-license="GPL-2.0"
-depends=""
-depends_dev=""
+license="GPL-2.0-or-later"
makedepends="cyrus-sasl-dev gdbm-dev gettext-dev gpgme-dev libidn-dev
ncurses-dev openssl-dev notmuch-dev bsd-compat-headers libxslt tcl
docbook-xsl perl w3m"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
@@ -27,6 +24,10 @@ build() {
make
}
+check() {
+ make test
+}
+
package() {
make DESTDIR="$pkgdir" install
install -Dm644 contrib/gpg.rc \